jQuery not supported.



rear brakes lights not working

1997 Chevy Z-71 4x4 extended cab 5.7

rear brakes lights not working

Postby skyking [OP] » Jul 07 2012, 11:56pm

Ok, i've attempted to try to fix this problem myself but need help.

First, the turn signal, hazards and bake lights went out, so i tried changing fuses and they kept blowing. So i looked online and read through a lots of post on different websites, and decided it was the multi-control on the left side of the steering wheel. I changed that out, put in new fuses and everything worked well for about a day. Then the turn signal started blowing fuses so I changed the flash relay under the dash. That seemed to solve that, has blown any fuses since I put that in (3 days ago). Then the brake tail lights went out, so I changed the brake light switch(under the steering wheel) and the relay (under the hood) but still no change. (i've kept looking online to try the different tips everyone has used to get their light working). so, then I changed out the tail lights sockets (circuit boards), and disconnected the trailer plug. I did use a tester on the plus wires and received amperage on both left, right and park wires, but none on the brake. Then I located the main connector, from the main wires from the front, just behind the spare tire and teased the power there. And it was the same, only left, right, and park but no brake. I traced the wires back pass the tank, fuel filter, cab, and up to the engine compartment, and they looked fine. The third brake works, both turn signals, and hazards, as well as parking lights.

And now, I am completely clueless as what to do next. I did check the voltage and amperage at the fuse box (between the door and dash) and its 12 volts (roughly) and 185mA..

any ideas what to do next? or if anyone has the brake light wiring available, I would greatly appreciate it.

basic run down of all parts replaced
multi-function on steering column
brake light switch
brake relay
flasher relay
all bulbs (third brake, both right and left tail lights)
tail light circuit boards
fuses

1997 Chevy Z-71 4x4 extended cab automatic with 5.7L engine, no modifications other than cosmetics
Original Poster
skyking
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jul 07 2012, 11:21pm
Years of membership: 2 years of membership2 years of membership
Group Membership:
Registered users

Re: rear brakes lights not working

Postby Machster69 » Jul 08 2012, 1:01am

Did you check the volatge at the brake light switch? before and after?

Heres the oldest diagram on gmupfitter, its for a 99, I dont see there being a huge difference, might help until you find a 97 diagram...
http://www.gmupfitter.com/body_builder_manuals.html
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7976
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: rear brakes lights not working

Postby SilverSurfer » Jul 09 2012, 4:04am

I think you're chasing a short. One I found was a wire running down the frame-rail that had some of the insulation melted off and would short whenever you went over a bump.

Does the 3rd brake light work when the others don't?
Image
User avatar
SilverSurfer
Staff Member
Staff Member
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2436
Topics: 51
Images: 82
Joined: Jun 27 2011, 1:29am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Phoenix, AZ
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Auto 2wd Posi
Group Membership:
Automotive Technicians
Global moderators
Registered users
Servicemen

Re: rear brakes lights not working

Postby skyking [OP] » Jul 10 2012, 12:23am

Someone recommended cutting off the trailer plug to eliminate the plug, so I went and cut off my trailer plug, and at first, it didn't do anything. So i stopped by a auto shop, they tested the wires and they narrowed it down to the maxi 30amp fuse under the hood, next to stop relay.

Apparently, the wires in the trailer plug wiggled loose, and caused a short. It caused the 30amp maxi fuse to burn out (although it did not have the tale-tale blown link or black spot), once the tech replied the fuse, the lights began to work. So now everything work well.

So yes, it was a short in the trailer plug.

thanks to Machster69 and SilverSurfer for their advice as well ..
Original Poster
skyking
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jul 07 2012, 11:21pm
Years of membership: 2 years of membership2 years of membership
Group Membership:
Registered users

Re: rear brakes lights not working

Postby Machster69 » Jul 10 2012, 12:28am

Excellent, you know I just recently learned that lesson also. That a fuse does not always break at the visible link. I work with an electrician at the FD, and we were diagnosing a friends radio... I traced power until I got to the fuse and I just looked at the fuse instead of actually checking it. He asks... did you test the fuse? I was like no, its good I looked at it... needless to say, he made me look like an ass then lectured me HA! Good guy love him... Good im glad you got the fix! Dont be a stranger now that your issue is fixed, stick around!
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7976
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: rear brakes lights not working

Postby skyking [OP] » Jul 10 2012, 1:18am

I'll sure to stay around a while, i'm sure I can help others with a problem they might have. I've done most of the work on my truck myself including changing fuel pump, pittman arms, and now the brake switch and muti-function switch.

And now I know to check the fuse, even if it looks okay.
Original Poster
skyking
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jul 07 2012, 11:21pm
Years of membership: 2 years of membership2 years of membership
Group Membership:
Registered users

Re: rear brakes lights not working

Postby sad-chevy » Oct 01 2014, 5:43am

Help needed. I have a 97 Chevy 1500 4x4 Z71 Ext Cab. It recently started blowing blinker and brake light fuses. Did you ever find the cause of your problems?
sad-chevy
Newbie
Newbie
Posts: 1
Joined: Oct 01 2014, 5:11am
Location: Alabama
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 1500 4x4 Z71 Ext Cab
Group Membership:
Registered users

Return to Electrical

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

rear work help working brakes lights looks still right same front think thanks back

It is currently Dec 19 2014, 4:56am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Electrical Forum
ElectricalDiscussion specific to electric components of trucks. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: Google Search Appliance and 13 guests