jQuery not supported.



stabilitrac/service traction control and truck won't start

stabilitrac/service traction control and truck won't start

Postby traut811 [OP] » Mar 27 2013, 2:01pm

On a 2009 5.3l w/ 6l80e.
I was driving the truck on the interstate, 60mph, when it began down shifting. Pulled over and now it won't start. The traction control, stabilitrac, and a check engine light are on. I haven't tested it, as I'm stuck on the side of the interstate right now. Engine/trans temps and oil levels are fine. I've been sitting here an hour, and it still won't start.
Any ideas??
Original Poster
User avatar
traut811
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 156
Topics: 15
Images: 3
Joined: Aug 21 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Location: Ste. Genevieve, MO
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

stabilitrac/service traction control and truck won't start

Postby Wepiii » Mar 27 2013, 2:07pm

Do you have onstar? They can run a diagnostic and give you the codes it is throwing. That would probably help someone figure out what it could be...
Wepiii
Combustion on 4 pistons [L2]
Combustion on 4 pistons [L2]
Posts: 455
Topics: 21
Joined: Jan 11 2013, 6:21am
Years of membership: 1 year of membership
Location: Powder springs, GA
Year: 2012
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.8L V8 LS
Group Membership:
Registered users

Re: stabilitrac/service traction control and truck won't sta

Postby traut811 [OP] » Mar 27 2013, 2:27pm

Wepiii wrote:Do you have onstar? They can run a diagnostic and give you the codes it is throwing. That would probably help someone figure out what it could be...

I do not.. I'll have to wait for a tow before I can scan it I guess.
Original Poster
User avatar
traut811
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 156
Topics: 15
Images: 3
Joined: Aug 21 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Location: Ste. Genevieve, MO
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

Re: stabilitrac/service traction control and truck won't sta

Postby Z15 » Mar 27 2013, 2:50pm

I would be tempted to disconnect the battery for a while, negative cable only, then try to restart.
Mike
Image Dealer

Image
User avatar
Z15
Recognized Supplier
Recognized Supplier
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2479
Topics: 126
Images: 8
Joined: Jun 02 2010, 7:24pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Hubbell, Michigan
Year: 2012
Make/Model: GMC Sierra
Variant: Denali
Extra Info: AWD 6.2L
Group Membership:
Vendors
Registered users
Servicemen

Re: stabilitrac/service traction control and truck won't sta

Postby traut811 [OP] » Mar 27 2013, 5:59pm

Finally home, what a morning..
Hooked up the scanner and five codes turned up. All fuel related (low pressure on rail and fuel pump power I think, I'll get codes on here in a bit). Possible it just went out while driving and made the truck start down shifting?
Original Poster
User avatar
traut811
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 156
Topics: 15
Images: 3
Joined: Aug 21 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Location: Ste. Genevieve, MO
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

Re: stabilitrac/service traction control and truck won't sta

Postby traut811 [OP] » Mar 28 2013, 3:47pm

I charged the battery and truck started and ran fine with no issues. Only thing still on is the stabilitrak/service traction control. No more fuel pump cel's. Is it possible the fuel pump just got hot and stopped working? This concerns me.
Fuel pump pressure readings are fine right now.
Original Poster
User avatar
traut811
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 156
Topics: 15
Images: 3
Joined: Aug 21 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Location: Ste. Genevieve, MO
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

stabilitrac/service traction control and truck won't start

Postby Wepiii » Mar 28 2013, 5:17pm

Wish I could help but I have no clue. I followed your other thread about the rebuild, I hope you get it figured out man!
Wepiii
Combustion on 4 pistons [L2]
Combustion on 4 pistons [L2]
Posts: 455
Topics: 21
Joined: Jan 11 2013, 6:21am
Years of membership: 1 year of membership
Location: Powder springs, GA
Year: 2012
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.8L V8 LS
Group Membership:
Registered users

Re: stabilitrac/service traction control and truck won't sta

Postby 09chevyman » Mar 28 2013, 5:40pm

traut811 wrote:I charged the battery and truck started and ran fine with no issues. Only thing still on is the stabilitrak/service traction control. No more fuel pump cel's. Is it possible the fuel pump just got hot and stopped working? This concerns me.
Fuel pump pressure readings are fine right now.

I may be wrong on this but I swear I remember reading in here some where that the stabilitrac/ traction control cel is GM's like default code for various systems in our trucks. You may end up taking it to them for that one [#%!?] hope you don't have to though. Maybe some one can help. Do a search on (stabilitrac/traction control cel) it can be a variety of things.
Image
Onlyina_Chevy: but that's not what you said.
Onlyina_Chevy: You can try to make yourself correct, but it won't work.
User avatar
09chevyman
Staff Member
Staff Member
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 6353
Topics: 62
Images: 57
Joined: Jan 30 2013, 2:14pm
Years of membership: 1 year of membership
Location: Georgia, where the dirt roads end at the woodlands.
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L 4x4 3.73 gears
Group Membership:
Global moderators
Registered users

Return to Electrical

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

help still right fuel stabilitrac traction service thing truck control start check side power think engine trucks light

It is currently Oct 23 2014, 5:31pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Electrical Forum
ElectricalDiscussion specific to electric components of trucks. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 9 guests