jQuery not supported.



Turn/Flasher Module Problem

Turn/Flasher Module Problem

Postby mevans0486 [OP] » Oct 08 2010, 3:52pm

I had an issue late last year where my left turn signal would either not work, stick on or cause the 4 ways to come on. This was during the winter time and once it got warm the issue went away. I thought that was kinda odd, but being in a tight on money I figured there was not reason to fix what at the time was not broke. Anyways, it is cold again that the problem has resurfaced. However now the left turn signal is just not working. Right works completely fine, and the 4 ways, which are 2 ways right now, work as they should. After some digging, most routes pointed to the turn/flasher module, GM part # 15764135. I know that there is already another thread similar to this, but I know that this is the part that need changed. However in my searching I found that most places are recommending to not use the GM part # 15764135, which is a 2/4 way with trailering, but to use GM part # 10383321, which is a 3/6 way with trailering. I will be pulling a camper before to long, so is it a good idea to go ahead with the 3/6 way, or will the 2/4 way be Ok? As always, thank you in advanced!
Image
Mevans0486
Original Poster
User avatar
mevans0486
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 124
Topics: 14
Images: 29
Joined: Jul 02 2010, 3:39pm
Years of membership: 6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
Location: Illinois
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: LS 4.8L V8 Ext.Cab
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby koolz71 » Oct 25 2010, 2:49am

My flasher relay went bad as well..the dealer fixed it i dont know what part number they used but if u can use the 3/6 with no issues just use it that way your good to go when u upgrade
Image
koolz71
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2576
Topics: 95
Images: 46
Joined: Mar 13 2010, 11:24pm
Years of membership: 6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
Location: ohio
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: Z71
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby mevans0486 [OP] » Oct 29 2010, 8:19pm

Well, stupid me, I guess I totally missed the blown fuse... So replaced that and we are signaling again! Interesting that it was that side that I was messing with to see if the master controller on the door, to see if there was power there for a turn signal for a mirror.
Image
Mevans0486
Original Poster
User avatar
mevans0486
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 124
Topics: 14
Images: 29
Joined: Jul 02 2010, 3:39pm
Years of membership: 6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
Location: Illinois
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: LS 4.8L V8 Ext.Cab
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby koolz71 » Oct 30 2010, 7:49am

im glad u got the issue taken care of, and sometimes the simplest things are the hardest
Image
koolz71
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2576
Topics: 95
Images: 46
Joined: Mar 13 2010, 11:24pm
Years of membership: 6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership6 years of membership
Location: ohio
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: Z71
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby VASierraZ71 » Dec 20 2015, 12:34am

So I was having the left turn signal issue that was intermittent and would activate the "hazard" lights (all 4 signals flashing; 6 if you count the side mirrors). So I researched here, and found what I thought to be a pretty solid fix for the issue. Found a video on youtube where the directional relay was replaced on a vehicle with the same symptoms, and it immediately solved the problem.
Video here: https://www.youtube.com/watch?v=y4QVUBVVVpI

Well, i purchased the new part number recommended in the video (10383321) AC Delco part. Replaced it this morning and what do you know it solved my issue.

For about 5 hours.

And now the left turn signal won't even turn on when switched. hazard switch doesn't activate it either. I checked all of the fuses on the side panel (driver door side) and they are good. Can anyone help me out?

Thank you.
VASierraZ71
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 12
Topics: 1
Joined: Sep 12 2014, 12:53am
Years of membership: 1 year of membership
Location: NY
Year: 2005
Make/Model: GMC Sierra
Extra Info: 5.3L Vortec
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby Blizzard » Dec 20 2015, 2:13am

i had the same issue i pulled off the dash panel under the steering wheel there is a little oval box there i just wacked it on the pavement a few times and it worked again. not sure what the thing was called thow.
Image
User avatar
Blizzard
Shifting into Gear [L3]
Shifting into Gear [L3]
Posts: 1070
Topics: 31
Images: 1
Joined: Sep 25 2012, 9:17pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Grimsby ON.
Year: 2012
Make/Model: Chevrolet Silverado
Extra Info: 5.3l z71
Group Membership:
Registered users

Re: Turn/Flasher Module Problem

Postby VASierraZ71 » Dec 22 2015, 12:07pm

Update:
The LH signal has worked flawlessly since Sunday morning (2 full days now). Saturday afternoon was the only time it cut off completely. Not knowing anything about electronics in cars/trucks, does the computer just need 24 hrs or so to figure out there's a new part - recognizing it and having it work appropriately?

Or did I just get lucky, or should I expect the LH signal to shut off completely again?
VASierraZ71
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 12
Topics: 1
Joined: Sep 12 2014, 12:53am
Years of membership: 1 year of membership
Location: NY
Year: 2005
Make/Model: GMC Sierra
Extra Info: 5.3L Vortec
Group Membership:
Registered users

Return to Electrical

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

problem same turn work side flasher module used lights since thing right help anyone trucks wheel

It is currently Aug 27 2016, 4:04pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Electrical Forum
ElectricalDiscussion specific to electric components of trucks. Category for alternators or batteries, starters and ignition parts, anything 12v and electrical issue like fuses, circuitry, wire, terminals, switches, connectors, bulbs, relays, and wiring. Voltage and amperage diagnosis.
To create a new topic in Electrical, click this button:
Previous topic Next topic

Who is online

Users browsing this forum: Google Adsense [Bot] and 18 guests

Sitewide News Sitemaps & Feeds