jQuery not supported.



high idle PLEASE HELP!!!

high idle PLEASE HELP!!!

Postby daudrey5 [OP] » Nov 08 2011, 12:52am

Hi i am new to this forum and in desperate need of advice. I have a 96 1500 5.7 liter with 260'000 miles on it. For 2 years i have been battling a high idle issue off and on. i have put all new sensors on the engine. i have misted around the intake with starting fluid with no change as if a vaccum leak would turn up.she starts at about 2500 rpm and finally comes down to 1200 rpm after awhile. while holding on the brake in gear she tryies to rev and push causing me to bare on the brakes harder. i can go on the highway at 55-65 mph with my foot off the gas. i have changed the idle air control sensor 4 times with no luck. as well as changed every single sensor on the engine. i can pull the tube out of the valve cover on the passenger side and spray the throttle body with starting fluid and she wont rev or try to cut off. but when i spray starting fluid in the tube to the valve cover she will rev on that. if i block off the passenger side tube with a stick that goes to the valve cover she runs perfect but i get a strong whistling sound from down in the center of the engine but i can not tell where it is exactly. i plan to change the intake gasket to see if that helps. she also has a rough idle at 1200 ( her normal idle now) but when i speed up it clears out.
Some one please help me. Thanks.
Original Poster
daudrey5
Newbie
Newbie
Posts: 5
Topics: 1
Joined: Nov 08 2011, 12:32am
Years of membership: 2 years of membership2 years of membership
Location: Virginia
Year: 1996
Make/Model: Chevrolet Silverado
Extra Info: 5.7 ci
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby Dirtsc00tin185 » Nov 08 2011, 1:34am

could be the throttle cable is too tight. happened to me when i put a throttle body spacer on ,my truck.
Dirtsc00tin185
Combustion on 2 pistons [L2]
Combustion on 2 pistons [L2]
Posts: 250
Topics: 29
Images: 8
Joined: Nov 04 2011, 12:48am
Years of membership: 2 years of membership2 years of membership
Location: SoCal
Year: 2007
Make/Model: GMC Sierra
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby ASTE25 » Nov 08 2011, 1:52am

It's really hard to say, but I will say that those engines are prone to intake gaskets leaking. A vacuum leak can cause a high idle, if it is a small enough one. You may have an intake manifold leak on the bottom side of the engine at the lifter galley (I base this assumption by the fact that when you spray eather into the valve cover it changes the engine speed.)
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11001
Topics: 19
Images: 5
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: high idle PLEASE HELP!!!

Postby love4chevysilverado » Nov 08 2011, 6:53am

You probably have a leak like aste25 mentioned. Once replacing that if the problem still persists you might have issues with the throttle body, I seen this before in the ls gen motor, they get "sticky" tb's causing the high idle problem. Another thing is if you have an aftermarket tb, say from like bbk performance they need adjustments and tuning or else you'll have similiar problems

Best bet start with replacing the gasket

Hope that helped,
Max
Image
User avatar
love4chevysilverado
Firing on 8 cylinders [L1]
Firing on 8 cylinders [L1]
Posts: 80
Topics: 11
Images: 12
Joined: Feb 20 2011, 5:52am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: 23323
Year: 2001
Make/Model: Chevrolet Silverado
Extra Info: 6.0L 3500
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby daudrey5 [OP] » Nov 08 2011, 12:31pm

Thanks alot to all, that info has helped in my decision to replace the gasket. have been looking for other problems to save some work i guess. i will let you know what i come up with. also i had the tranny rebuilt and since i got it back it keeps blowing instrument/tail light fuses. it dont look as though any wires are pinched. anyone know of a cure for that?

Thanks again, Danny
Original Poster
daudrey5
Newbie
Newbie
Posts: 5
Topics: 1
Joined: Nov 08 2011, 12:32am
Years of membership: 2 years of membership2 years of membership
Location: Virginia
Year: 1996
Make/Model: Chevrolet Silverado
Extra Info: 5.7 ci
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby lzn197 » Nov 08 2011, 1:36pm

Does this truck have vacuum power brakes? I bet it is leaking internally. Squeeze the hose or disconnect it and see if idle drops.
Gordon
2004 Chevrolet Silverado Extended Cab Z71
Semi-retired Master Mechanic
User avatar
lzn197
ASE Certified
ASE Certified
4x4 High Mode [L3]
4x4 High Mode [L3]
Posts: 1810
Topics: 6
Images: 22
Joined: Apr 01 2010, 3:45pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Central Michigan
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: K1500 5.3L Z71 EX
Group Membership:
Automotive Technicians
Registered users

Re: high idle PLEASE HELP!!!

Postby daudrey5 [OP] » Nov 08 2011, 8:45pm

When i pull the vac line from the booster the idle rpm stays at the 1200 I had been idling for 2 yrs. It only runs rougher but maintains 1200. When I pull the same line from the back side of the intake she revs really high. Enough to scare you so I plugged it back in really fast. She does have brake boost vac.
Original Poster
daudrey5
Newbie
Newbie
Posts: 5
Topics: 1
Joined: Nov 08 2011, 12:32am
Years of membership: 2 years of membership2 years of membership
Location: Virginia
Year: 1996
Make/Model: Chevrolet Silverado
Extra Info: 5.7 ci
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby daudrey5 [OP] » Nov 22 2011, 2:03am

Well got the chevy fixed. As it turns out she sucked the intake gasket into 2 and 4 cylinders. Runs like a champ now.
Original Poster
daudrey5
Newbie
Newbie
Posts: 5
Topics: 1
Joined: Nov 08 2011, 12:32am
Years of membership: 2 years of membership2 years of membership
Location: Virginia
Year: 1996
Make/Model: Chevrolet Silverado
Extra Info: 5.7 ci
Group Membership:
Registered users

Re: high idle PLEASE HELP!!!

Postby ASTE25 » Nov 22 2011, 7:49am

That's good to hear. Did you do the repair yourself?
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11001
Topics: 19
Images: 5
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: high idle PLEASE HELP!!!

Postby daudrey5 [OP] » Nov 22 2011, 3:55pm

I started too but got called back to work so a buddy of mine did it for really cheap.
Original Poster
daudrey5
Newbie
Newbie
Posts: 5
Topics: 1
Joined: Nov 08 2011, 12:32am
Years of membership: 2 years of membership2 years of membership
Location: Virginia
Year: 1996
Make/Model: Chevrolet Silverado
Extra Info: 5.7 ci
Group Membership:
Registered users
Next

Return to Engine

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

help back high engine work thanks idle light problem mine same still

It is currently Oct 24 2014, 11:19am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Engine Forum
EngineThis is where all of our engine discussion and conversation takes place. Talk about engine diagnostics, adjustments, modifications, performance and care. Motor tuning and repair to gain horsepower and fuel efficiency.
To create a new topic in Engine, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 2 guests