jQuery not supported.



Oil Pressue Gauge Not Working

Oil Pressue Gauge Not Working

Postby gadawg31 [OP] » Jan 12 2012, 4:23pm

Hello all,

New here and hope to find some info about my 2006 GMC Sierra. I noticed this morning that my oil gauge is all the way to the right, showing 80lbs pressure. It was working a couple of days ago, but now it will only go over to the far right. Any suggestions on how to test the sensor? Also, where is it located on the engine? I can't seem to find it any where. I know it is not like the old model vehicles, since it probably goes through the computer system. Any chance there may be something up with the computer? I have received no engine light or codes. Thanks in advance for any and all suggestions/advise.

JD
Original Poster
gadawg31
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 23
Topics: 7
Blogs: 0
Joined: Jan 12 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Year: 2006
Make/Model: GMC Sierra
Group Membership:
Registered users
Related Topics  fuel gauge/oil pressure gauge issue   Changed oil sending Unit. oil pressure gauge pegged on high   trans gauge not working   gauge light not working 03 silverado   Temp Gauge Not Working Properly   Oil Gauge   oil pressure gauge   Oil Pressure Gauge dropped to ZERO!   Oil pressure gauge issue   Oil Pressure Problem or Gauge?   Oil pressure gauge problems   Oil pressure Gauge fluctuates when idle and when driving   Lifter Noise, Oil Pressure gauge fluctuates, starter issue   Four gauge dash to six gauge 
Engine Sponsor
Advertise Here

Re: Oil Pressue Gauge Not Working

Postby ASTE25 » Jan 12 2012, 9:47pm

My guess would be a bad oil pressure sensor. I believe it is on the top rear of the engine near the drivers side cylinder head. I think you can do like the old ones and ground the lead or pull it off the sensor to see if the gauge changes, but you may want to get a factory service manual to find out for sure how to check it.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10907
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Oil Pressue Gauge Not Working

Postby 2003Z71 » Jan 13 2012, 4:24am

The oil pressure gauge in my 2003 did the same thing about 6 months ago. I just figured it was the sensor since everything else worked on my cluster. It is infact where ASTE25 says it is. Not real fun to get to. I scraped up my wrist on the fuel line clamps trying to get back to it. Also it takes a special socket; I think I got it from NAPA. Once the new sensor was installed it's worked perfectly ever since.
Image
Recon LED cab lights*AirLift Bags & Compressor*Edelbrock IAS Shocks*ReadyLift Leveling Kit*K&N CAI*Smittybilt Bars & Bumper Guard*MagnaFlow Cat Back
User avatar
2003Z71
Combustion on 6 pistons [L2]
Combustion on 6 pistons [L2]
Posts: 646
Topics: 40
Images: 38
Blogs: 0
Joined: Feb 13 2011, 5:36am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Denver CO
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 1500 Z71 5.3L RegCab
Group Membership:
Registered users

Re: Oil Pressue Gauge Not Working

Postby gadawg31 [OP] » Jan 13 2012, 5:05pm

Hey, thanks for the update. As bad as it sounds, regarding position, I really hope it is the sensor and not the stepper motor. I know the stepper motor sounds easy to do, but I have real bad luck with electronics. Going to get a new sensor today and try it out. Thanks again for the info.

JD
Original Poster
gadawg31
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 23
Topics: 7
Blogs: 0
Joined: Jan 12 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Year: 2006
Make/Model: GMC Sierra
Group Membership:
Registered users

Re: Oil Pressue Gauge Not Working

Postby ASTE25 » Jan 13 2012, 7:30pm

Keep us updated.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10907
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Oil Pressue Gauge Not Working

Postby gadawg31 [OP] » Jan 17 2012, 4:40pm

It was definately the oil pressure sensor. I replaced it this weekend and it was not that bad. AFter a little prep work, it was simply a unscrew the old and screw in the new. As I mentioned on another topic, you definately need to remove the small plastic piece sticking out near the fuel line. That made the already small opening a little more accessable. The special socket is a plus and autozone has it for $10. Overall cost was $49.24

JD
Original Poster
gadawg31
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 23
Topics: 7
Blogs: 0
Joined: Jan 12 2012, 4:07pm
Years of membership: 2 years of membership2 years of membership
Year: 2006
Make/Model: GMC Sierra
Group Membership:
Registered users

Re: Oil Pressue Gauge Not Working

Postby ASTE25 » Jan 18 2012, 2:46am

Glad you got it fixed .
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10907
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Return to Engine

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

since fuel think engine gauge working pressue thanks side today again thing keep another installed same work right rear back light check

It is currently Aug 23 2014, 4:21pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Engine Forum
EngineThis is where all of our engine discussion and conversation takes place. Talk about engine diagnostics, adjustments, modifications, performance and care. Motor tuning and repair to gain horsepower and fuel efficiency.
To create a new topic in Engine, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests