jQuery not supported.



P0300 code

random multiple cylinder misfire

P0300 code

Postby green97z71 [OP] » Jun 06 2011, 12:49pm

ok fellas, i really need some input on this problem. my truck is a 97 silverado with the vortec 5.0 and 4L60E tranny. problem is a horrible miss in the motor. engine light was not on but hooked my scanner up and the P0300 code came up. i replaced the plugs, plug wires and coil to no avail. didnt make a difference at all. has no power what so ever. truck has 169k on the clock and is all stock with the exception of a 3" flowmaster and a gutted cat (was like this when i bought it last year)....... anybody have any suggestions on what i can do
Original Poster
green97z71
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 20
Topics: 6
Blogs: 0
Joined: Jan 10 2011, 6:49pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Pennsylvania
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 5.0 v8 4x4 z71
Group Membership:
Registered users
Related Topics  P0300 code   5.3 P0300 Code   03 Silverado 5.3 dreaded p0300 code   P0405 + P0300 code - looking for ideas   P0300 HELP   P0300   In need of help with a p0300   Code P0141 Bank 1 Sensor 2 o2 sensor throwing code   p0300 diagnosis   P0300 diagnosis help   P0300,p0171,174   can't figure out a problem, p0300 dtc.   P0300 Random Misfire Occuring Randomly   P0300 flashing at 2100 RPM - Out of things to fix! 
Engine Sponsor
Advertise Here

Re: P0300 code

Postby heelsparky0501 » Jun 07 2011, 3:10am

Maby an intake gasket leak? Im Not sure how to check for it other then to open it up, i hear they fail commonly on these engines....

Multiple Clogged Injectors?

I just had a problem with my truck but the misfire was only 1 cylinder, i did everything you did but it ended up being the injector.

Good Luck
heelsparky0501
Firing on 4 cylinders [L1]
Firing on 4 cylinders [L1]
Posts: 47
Topics: 10
Blogs: 0
Joined: May 03 2011, 5:23pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Year: 1999
Make/Model: GMC Sierra
Extra Info: 4.8L
Group Membership:
Registered users

Re: P0300 code

Postby green97z71 [OP] » Jun 07 2011, 1:19pm

I replaced the intake gaskets right after i bought the truck last april. And that was the first thing i checked. Thank you for reminding me though! A good friend of mine from the dealership told me it sounds like injector trouble. Just like you had mentioned. Im gonna check ebay for a set of injectors. Thanks for the reply and help!
Original Poster
green97z71
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 20
Topics: 6
Blogs: 0
Joined: Jan 10 2011, 6:49pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Pennsylvania
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 5.0 v8 4x4 z71
Group Membership:
Registered users

Re: P0300 code

Postby harper » Jun 07 2011, 2:39pm

did you check the cap and rotor because these like to crack on my dads so moisure gets in there and wont run and misses. worth a try
i would rather walk then drive a toyota
harper
Firing on 7 cylinders [L1]
Firing on 7 cylinders [L1]
Posts: 75
Topics: 8
Images: 2
Blogs: 0
Joined: Jan 19 2011, 3:35pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: upper peninsula, mi
Year: 2001
Make/Model: Chevrolet Silverado
Extra Info: 4.8 4x4
Group Membership:
Registered users

Re: P0300 code

Postby green97z71 [OP] » Jun 07 2011, 8:59pm

harper
I did overlook the cap and rotor. Guess since i replaced them when i did the intake gaskets i figured they were still good. One of the first things i should have checked though. Thanks for bringing that to my attention. I will definitely try that next!!
Original Poster
green97z71
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 20
Topics: 6
Blogs: 0
Joined: Jan 10 2011, 6:49pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Pennsylvania
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 5.0 v8 4x4 z71
Group Membership:
Registered users

Re: P0300 code

Postby green97z71 [OP] » Jun 08 2011, 12:34pm

well last night i put a new cap and rotor on, still no difference in the way it runs. still has the misfire code as well
Original Poster
green97z71
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 20
Topics: 6
Blogs: 0
Joined: Jan 10 2011, 6:49pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Pennsylvania
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 5.0 v8 4x4 z71
Group Membership:
Registered users

Re: P0300 code

Postby BooNDocK Sai8 » Aug 01 2011, 10:39pm

Disconnect the cat in the front and see if it runs better. The other thing you could check is the egr valve the o2 sensor duel filter. Injectors you can check while its running put a rod to the end of one and listen to the other end for a double tick. That means it's good. I'm going thru this problem now and it turned out to be a clogged cat on one bank. Started with a p0300 code. Ran horrible could make it up a hill, took cats off and runs fine. $350 in diagnosis later.
BooNDocK Sai8
Newbie
Newbie
Posts: 8
Topics: 1
Images: 0
Blogs: 0
Joined: Jul 28 2011, 10:25pm
Years of membership: 2 years of membership2 years of membership
Location: New England
Year: 2001
Make/Model: Chevrolet Silverado
Extra Info: 4.8 vortec
Group Membership:
Registered users

Re: P0300 code

Postby green97z71 [OP] » Aug 02 2011, 2:01am

Well sorry guys it's been till now that I am posting what I did to fix the problem. Hard to get a break from work working 7 days a week on 3rd shift. Anyways... I ended up replacing injectors #3 and #7 as they were found to be bad. (Glad I have buddies that work at the GM dealership!!) Wasn't too bad to replace them but she runs so much better and mpg has improved a smidge. For it having 170,000+ miles on it
Original Poster
green97z71
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 20
Topics: 6
Blogs: 0
Joined: Jan 10 2011, 6:49pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Pennsylvania
Year: 1997
Make/Model: Chevrolet Silverado
Extra Info: 5.0 v8 4x4 z71
Group Membership:
Registered users

Re: P0300 code

Postby 2011 GMC Crew » Aug 02 2011, 2:10am

Congrats on getting it fixed, and thanks for following up! Too many of these threads just stop without the final fix being identified.
User avatar
2011 GMC Crew
Firing on 3 cylinders [L1]
Firing on 3 cylinders [L1]
Posts: 37
Topics: 1
Blogs: 0
Joined: Jun 07 2011, 4:17am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: San Diego
Year: 2011
Make/Model: GMC Sierra
Extra Info: 1500 Crew
Group Membership:
Registered users

Return to Engine

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

problem thanks still first make code light guys check miles getting engine work help front right stock mine

It is currently Jul 25 2014, 11:17pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Engine Forum
EngineThis is where all of our engine discussion and conversation takes place. Talk about engine diagnostics, adjustments, modifications, performance and care. Motor tuning and repair to gain horsepower and fuel efficiency.
To create a new topic in Engine, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 10 guests

carid home silverado truck parts at carid replacement side view mirrors store custom truck parts store putco chrome accessories and trim store