jQuery not supported.



po157

new cats/threw a code?

po157

Postby chrisg5.3 [OP] » Aug 29 2011, 2:41am

i have a 99 silverado, 5.3L, ext cab Z71. truck has 138,000 miles on her. cold air, flowmaster exhaust, and a hypertech tune. noticed the usual rotten egg smell a week or so ago, so i ordered a set of universal cats and had them put on. now im throwing the po157 code. i replaced the o2 sensors when i purchased the truck in january. any ideas on why new cats would cause this? truck runs perfect other than the check engine light
Original Poster
chrisg5.3
Newbie
Newbie
Posts: 8
Topics: 2
Joined: Feb 19 2011, 10:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 5.3 z71 extended cab
Group Membership:
Registered users

Re: po157

Postby adams99z71 » Aug 29 2011, 3:32pm

po157 is "o2 sensor circut low voltage (post converter right bank). its nothing to worry about, the rear o2 sensors only monitor the efficiency of the catalytic converters. basicly the new cat doesn't do as good of a job cleaning the exhaust as the stock cat so theirs less oxygen in the system for the sensor to read resulting in lower voltage and a trouble code. one thing you could try if the SES light bothers you is switch the o2 sensor with the driver side sensor, then drive around for about 50miles then check to see if a p0137 code pops up (same thing just the left side) . if that happens your sensors bad. if you get the same po157 code then that could be a sign theres a hole in the left side exhaust pipe or the right side cat is damaged from shipping or manufacturing. let us know what you find.
nbs99 z71 325ci v8, stock 4wheel disc brakes, no cats, flow master classic 40 series, rhino line, custom fog lights, cb, bully dog tunner, 4:10 locker, airbag load leveling, 205,000miles.
User avatar
adams99z71
Armed Forces
Armed Forces
Combustion on 6 pistons [L2]
Combustion on 6 pistons [L2]
Posts: 625
Topics: 30
Images: 0
Joined: Nov 27 2010, 6:28am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: san diego
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 325ci Z71 ext cab LS
Group Membership:
Automotive Technicians
Registered users
Servicemen

Re: po157

Postby chrisg5.3 [OP] » Aug 30 2011, 4:41am

ill try swaping the 02 sensors this weekend and see if that is the issue. thanks for the input
Original Poster
chrisg5.3
Newbie
Newbie
Posts: 8
Topics: 2
Joined: Feb 19 2011, 10:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 5.3 z71 extended cab
Group Membership:
Registered users

Re: po157

Postby chrisg5.3 [OP] » Sep 06 2011, 12:54am

cleared the code, switched the O2 sensors and the code came back within 40 miles or so. the only thing that comes to mind is that maybe i have a broken wire on that side?
Original Poster
chrisg5.3
Newbie
Newbie
Posts: 8
Topics: 2
Joined: Feb 19 2011, 10:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 5.3 z71 extended cab
Group Membership:
Registered users

Re: po157

Postby adams99z71 » Sep 06 2011, 1:22am

yeah could just be that a wire got burned, pinched. if i were you i'd give the guy who installed it a call. so much easier to diagnose in person. best of luck to you.
nbs99 z71 325ci v8, stock 4wheel disc brakes, no cats, flow master classic 40 series, rhino line, custom fog lights, cb, bully dog tunner, 4:10 locker, airbag load leveling, 205,000miles.
User avatar
adams99z71
Armed Forces
Armed Forces
Combustion on 6 pistons [L2]
Combustion on 6 pistons [L2]
Posts: 625
Topics: 30
Images: 0
Joined: Nov 27 2010, 6:28am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: san diego
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 325ci Z71 ext cab LS
Group Membership:
Automotive Technicians
Registered users
Servicemen

Return to Exhaust

Common search terms

thing exhaust light check miles side post call system drive issue installed back thanks same right engine rear stock

It is currently Oct 02 2014, 9:24am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Exhaust Forum
ExhaustTopics regarding exhaust systems beginning at the headers down the pipes and through the catalytic converter and the mufflers and exhaust tips. We can also discuss emissions, performance cat back exhausts, or any exhaust related topics.
To create a new topic in Exhaust, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 3 guests