jQuery not supported.



Erratic behavior of the 4x4 buttons

Help with 4 wheel drive selector

Erratic behavior of the 4x4 buttons

Postby bradk600 [OP] » Oct 26 2011, 1:48pm

Hi I just bought a new to me 2003 GMC Sierra Z71 and I was wondering why every morning or when I leave work the 4 wheel drive selector (to the left of the steering wheel) has selected something different. I prefer it in 2 hi just for my normal driving but the other morning the Auto 4wd was selected but i didn't notice until i was half way to work (20kms down the 401) I just left it because i didn't want to be pushing buttons doing 120 kmh down the 401. Some mornings just the little red neutral light will be lit up and no others, this morning the 4 lo was engaged. I noticed that because it was turning hard in my driveway. Is it hard on it to drive in auto 4wd on dry roads and down the highway? I have never owned a truck with auto 4wd before. My previous truck was a 2000 GMC sonoma ZR2 and it didn't have auto, just 2hi, 4hi, 4lo. Thanks in advance for the help. I just got the truck and am trying to get everything figured out. Brad
Original Poster
bradk600
Newbie
Newbie
Posts: 9
Topics: 1
Joined: Oct 26 2011, 1:34pm
Years of membership: 2 years of membership2 years of membership
Location: ontario
Year: 2003
Make/Model: GMC Sierra
Extra Info: 1500 5.3 liter Z71
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby country1911 » Oct 26 2011, 3:05pm

Sometimes the solder on the back of the board in the switch will go bad causing some weird issues. Maybe look at that and if you are not comfortable with it, you could just replace the switch. $50 is probably the cheapest solution.
User avatar
country1911
Shifting into Third Gear [L3]
Shifting into Third Gear [L3]
Posts: 1327
Topics: 41
Images: 2
Joined: Sep 20 2011, 3:21pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Galesburg, MI
Year: 2007
Make/Model: Chevrolet Silverado
Variant: VHO/Vortec Max
Extra Info: LTZ 4X4
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby bradk600 [OP] » Oct 26 2011, 3:09pm

I will look into that....i know i am having some serious issues with my speedometer and instrument cluster right now (I have been reading and sounds like a very common problem)....they must have gotten there circuit boards by the lowest bidder LOL. That sounds like a good place to start. It hasn't done it when i have been driving just when i shut if off and restart it.
Original Poster
bradk600
Newbie
Newbie
Posts: 9
Topics: 1
Joined: Oct 26 2011, 1:34pm
Years of membership: 2 years of membership2 years of membership
Location: ontario
Year: 2003
Make/Model: GMC Sierra
Extra Info: 1500 5.3 liter Z71
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby country1911 » Oct 26 2011, 3:33pm

It seems the first indication of bad solder is a service 4wd message at startup. I am just starting to get this when it is cold and the connections seperate.
User avatar
country1911
Shifting into Third Gear [L3]
Shifting into Third Gear [L3]
Posts: 1327
Topics: 41
Images: 2
Joined: Sep 20 2011, 3:21pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Galesburg, MI
Year: 2007
Make/Model: Chevrolet Silverado
Variant: VHO/Vortec Max
Extra Info: LTZ 4X4
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby bradk600 [OP] » Oct 26 2011, 5:35pm

I haven't gotten any error messages yet....just the buttons are acting up.
Original Poster
bradk600
Newbie
Newbie
Posts: 9
Topics: 1
Joined: Oct 26 2011, 1:34pm
Years of membership: 2 years of membership2 years of membership
Location: ontario
Year: 2003
Make/Model: GMC Sierra
Extra Info: 1500 5.3 liter Z71
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby bradk600 [OP] » Oct 27 2011, 12:03pm

I actually just got the service 4wd system for the first time yesterday.....the little red neutral light was on and when pushing the 2hi button or any of the buttons nothing happened as in none of the lights would light up or change from 2 to 4 wheel. So i shut the truck off and restarted it and then i could put it in 2hi and it stayed there. Does anybody know what the little red neutral light is for. I know that you can drive with it on but what does it do or mean? Thanks in advance.
Original Poster
bradk600
Newbie
Newbie
Posts: 9
Topics: 1
Joined: Oct 26 2011, 1:34pm
Years of membership: 2 years of membership2 years of membership
Location: ontario
Year: 2003
Make/Model: GMC Sierra
Extra Info: 1500 5.3 liter Z71
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby Z15 » Oct 27 2011, 12:11pm

Just a fyi

1999-07 style trucks were inundated with lots of problems with the push buttons and other electronic 4x4 components. I had a 99, 01 and 04 GMC Sierra's and all 3 had some problem with the poor electronics, all 3 had the oem dash switch replaced and the 01 had a motor in the TC replaced, all when relatively new.

With the NBS trucks they have appeared to correct all these problems with the Rotary selector.
Mike
Image Dealer

Image
User avatar
Z15
Recognized Supplier
Recognized Supplier
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2432
Topics: 125
Images: 8
Joined: Jun 02 2010, 7:24pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Hubbell, Michigan
Year: 2012
Make/Model: GMC Sierra
Variant: Denali
Extra Info: AWD 6.2L
Group Membership:
Vendors
Registered users
Servicemen

Re: Erratic behavior of the 4x4 buttons

Postby johnta1 » Oct 30 2011, 11:32pm

I just got a 2003 also.
It is doing this, too, except it is not actually in 4 low when the 4low light is lit up.
(in high gear it isn't in a low gear like when it is actually in 4low)

The computer thinks it is though it seems.
Sometimes it will keep the tranny in high gear with no down shifting.
Starts out in high also.
(a real pig taking off)

It will sometimes have the red light on, which I understand if for neutral in transfer case.
Which I think would not let the truck move if it was actually in neutral?

Is this just the 4x4 push button cluster also?
johnta1
Newbie
Newbie
Posts: 8
Topics: 2
Joined: Oct 30 2011, 11:23pm
Years of membership: 2 years of membership2 years of membership
Location: Florida
Year: 2003
Make/Model: GMC Sierra
Extra Info: 5.3L Z-71
Group Membership:
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby EKinMN » Oct 31 2011, 2:41am

Yup, pretty sure it is.
I had an 2003 Avy that did the same thing. Start with the cluster....
Image
2010 Sierra All-Terrain. Mods: Range AFM delete, R.C. 2" level, 275/65-18 tires, mudflaps, soft toneau cover, bed mat, side steps, and HIDGuy 35w 5000k HID's
User avatar
EKinMN
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 8092
Topics: 146
Images: 33
Joined: Oct 08 2010, 4:16am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Oakdale, MN
Year: 2010
Make/Model: GMC Sierra
Extra Info: All Terrain Z71
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Erratic behavior of the 4x4 buttons

Postby bradk600 [OP] » Oct 31 2011, 12:03pm

By Cluster I am assuming that you mean the 4X4 push buttons. What exactly is the red neutral light for.....like Johnta1 said i am assuming that if the red neutral light is lit up that the truck would not move.
Original Poster
bradk600
Newbie
Newbie
Posts: 9
Topics: 1
Joined: Oct 26 2011, 1:34pm
Years of membership: 2 years of membership2 years of membership
Location: ontario
Year: 2003
Make/Model: GMC Sierra
Extra Info: 1500 5.3 liter Z71
Group Membership:
Registered users
Next

Return to Transmission/Drivetrain

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

light wheel problem first erratic thanks buttons behavior done bought keep pretty lights thing right think back help work same trucks

It is currently Sep 24 2014, 3:39am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Transmission/Drivetrain Forum
Transmission/DrivetrainTransmission and drivetrain related components. Discuss automatic and manual trans repairs and performance or talk about driveshafts or rear-ends and differentials. Diagnostics of 4-speed, 5-speed, or even 6-speed transmissions.
To create a new topic in Transmission/Drivetrain, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 8 guests