jQuery not supported.



Installing Shifter Linkage Issues

Installing Shifter Linkage Issues

Postby SUNDOWNCHEVY [OP] » Sep 02 2012, 8:44pm

I'm new here and this was the closest topic for my issue,I have a 1998 k1500,Never had a shifting issue till yesterday,got in the truck cranked it up put my foot on the brake and got ready to shift out of park It did nothing!! Looked on a couple of forums and someone suggested unplugging a sensor with a rod going through it,Once done they were able to shift freely...Not only was that a issue the old linkage was sorta loose and worn out,so my buddy came over and took the old one off,replaced with a new one and now it's really stiff shifting from park to drive and won't return to park unless guided from underneath...Anyone had this problem and a solution maybe ?
Original Poster
User avatar
SUNDOWNCHEVY
Newbie
Newbie
Posts: 5
Topics: 1
Images: 3
Joined: Sep 02 2012, 8:19pm
Years of membership: 2 years of membership2 years of membership
Location: United States
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.7 liter vortec 4x4
Group Membership:
Registered users

Installing Shifter Linkage Issues

Postby Machster69 » Sep 03 2012, 1:53am

Am i understanding, the shift lever will not unlock bc it is acting like the brake is not depressed?
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7975
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Installing Shifter Linkage Issues

Postby country1911 » Sep 03 2012, 1:55am

I had an issue with this a while back with my 02. It turned out to be the cable was loose in the bracket causing it to not go into park freely. Make sure everything is tight and as it should be underneath.
User avatar
country1911
Shifting into Third Gear [L3]
Shifting into Third Gear [L3]
Posts: 1327
Topics: 41
Images: 2
Joined: Sep 20 2011, 3:21pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Galesburg, MI
Year: 2007
Make/Model: Chevrolet Silverado
Variant: VHO/Vortec Max
Extra Info: LTZ 4X4
Group Membership:
Registered users

Re: Installing Shifter Linkage Issues

Postby ASTE25 » Sep 03 2012, 4:27am

It's hard to tell from your description, but, did you replace the shifter cable with a new one? The old one may have corrosion inside and is causing it to sieze.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11074
Topics: 19
Images: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Installing Shifter Linkage Issues

Postby SUNDOWNCHEVY [OP] » Sep 03 2012, 4:52am

Yeah the cable was replaced,and now will shift from park through 1rst fine,it's just really stiff!! When you try to return it back to park it is loose feeling and has to be manually shifted not only by someone on the inside but underneath as well....
Original Poster
User avatar
SUNDOWNCHEVY
Newbie
Newbie
Posts: 5
Topics: 1
Images: 3
Joined: Sep 02 2012, 8:19pm
Years of membership: 2 years of membership2 years of membership
Location: United States
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.7 liter vortec 4x4
Group Membership:
Registered users

Re: Installing Shifter Linkage Issues

Postby ASTE25 » Sep 03 2012, 4:56am

I would suggest checking to make sure it did not get bent while installing it. That's about the only thing I can think of that would cause a problem. As stated above, make sure it is secured in all mounting locations.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11074
Topics: 19
Images: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Installing Shifter Linkage Issues

Postby SUNDOWNCHEVY [OP] » Sep 03 2012, 5:01am

To be honest GM did a fine job of adding this cable by the factory,I would've never imagined a cable as long as it is for such a short distance,me and my buddy are gonna try and take another crack at it in the morning....I really appreciate the help,Also while I'm here can any of you tell me the best way to get a picture to the specs so I can make a profile pic ?
Original Poster
User avatar
SUNDOWNCHEVY
Newbie
Newbie
Posts: 5
Topics: 1
Images: 3
Joined: Sep 02 2012, 8:19pm
Years of membership: 2 years of membership2 years of membership
Location: United States
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.7 liter vortec 4x4
Group Membership:
Registered users

Re: Installing Shifter Linkage Issues

Postby ASTE25 » Sep 03 2012, 7:47am

I use paint and just resize it.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11074
Topics: 19
Images: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Installing Shifter Linkage Issues

Postby Machster69 » Sep 03 2012, 2:47pm

Paint :D :D :D

*sign* lol you old timers crack me up...
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7975
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Installing Shifter Linkage Issues

Postby SUNDOWNCHEVY [OP] » Sep 11 2012, 9:41am

Thanks for the tip on the pic and I will handle that shortly,as for the cable I had to put it in the shop and get a pro to look at it...Turns out the damn cable from O'Reily's is made in Egypt and was not very durable,ended up buying a OEM Replacement for about $6 bucks more and it solved the problem.... Ehh Like a friend told me,"you can't win them all you know" lol :lol:
Original Poster
User avatar
SUNDOWNCHEVY
Newbie
Newbie
Posts: 5
Topics: 1
Images: 3
Joined: Sep 02 2012, 8:19pm
Years of membership: 2 years of membership2 years of membership
Location: United States
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.7 liter vortec 4x4
Group Membership:
Registered users
Next

Return to Transmission/Drivetrain

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

while problem make issues installing shifter back issue linkage long drive another anyone thanks think help done thing

It is currently Nov 27 2014, 12:43pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Transmission/Drivetrain Forum
Transmission/DrivetrainTransmission and drivetrain related components. Discuss automatic and manual trans repairs and performance or talk about driveshafts or rear-ends and differentials. Diagnostics of 4-speed, 5-speed, or even 6-speed transmissions.
To create a new topic in Transmission/Drivetrain, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 3 guests