jQuery not supported.



Shift problem no 3rd or 4th gear

shift prob

Shift problem no 3rd or 4th gear

Postby christruck [OP] » Jan 25 2011, 9:20pm

rebuilt trans had no prob for a month then no 3rd or 4th intermittently always shifted in less then 1/4 checked all grounds and pins all look good wired harness to trans shifted fine. prob not in trans? put in used vcm still the same. yesterday no shift for 1 mile pull over unplugged harness at trans 2nd with shifter in 1st or 2nd and 3rd in 3rd or D just as it should be again not in transmission? HELP! ps no codes scanner reads comp. is comanding solenoids also wired lights to top of trans harness into cab lights operate correctly even when no 3 & 4
Last edited by Austin on Jan 25 2011, 9:34pm, edited 1 time in total.
Reason: Tried to make it a little more comprehensible, not sure if I was successful.
Original Poster
christruck
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jan 25 2011, 7:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: wpb fl
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.0 vortex 4x4
Group Membership:
Registered users

Re: Shift problem no 3rd or 4th gear

Postby jepics » Jan 25 2011, 9:47pm

Christruck,
Lets see if I understand. You either had your trans rebuilt or a rebuilt one put in a month ago. After a month, gremlins started showing up:

3rd & 4th gears would work sometimes, other times not.

You checked all the wiring, pins and plugs and all look good.

You put in a used vacuum control module and that didn't change anything.

When you drove a mile yesterday, it didn't shift at all - just stayed in 1st? You unplugged at the transmission end with the shift lever in various positions to see if it made any difference and it didn't?

I am surprised it is not throwing any codes. There's got to be something loose or screwed up in the wiring. Did you say you wired lights to the commanding solenoids to test if they are being activated by the computer? And the solenoids are active even when it doesn't shift into 3rd or 4th?

I would guess there are electronics in the tranny that are not working right.
If you want to do what you want to do, you have to do what you have to do.
--John
5320
User avatar
jepics
Combustion on 8 pistons [L2]
Combustion on 8 pistons [L2]
Posts: 831
Topics: 51
Images: 24
Joined: Sep 02 2010, 9:16pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Rockland County NY
Year: 2009
Make/Model: GMC Sierra
Extra Info: SLE 5.3 V8 4x4 Z71
Group Membership:
How-to Authors
Registered users

Re: Shift problem no 3rd or 4th gear

Postby christruck [OP] » Jan 26 2011, 1:19pm

these trans have no vacum modulator,i changed the computer.the thing is i wire up a new harness to just the solinoids apply batt + to the solinoids and ground the negs at the correct time going down the road all shifts all gears,so the electronics in the tranny are working.with the harness unplugged its in 3rd as it should be.if it was the trans it should still be having a problem with harness unplugged
Original Poster
christruck
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jan 25 2011, 7:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: wpb fl
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.0 vortex 4x4
Group Membership:
Registered users

Re: Shift problem no 3rd or 4th gear

Postby Hartski » Jan 26 2011, 1:32pm

Maybe a pinched or broken wire somewhere in the harness? If you've had major work done to it recently, I know how bad wiring harnesses get in the way of things....
in omnia paratus
Hartski
Shifting into Fourth Gear [L3]
Shifting into Fourth Gear [L3]
Posts: 1491
Topics: 6
Images: 23
Joined: Jun 24 2010, 9:25pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Iowa
Year: 2010
Make/Model: Chevrolet Silverado
Extra Info: LTZ Z71
Group Membership:
Registered users

Re: Shift problem no 3rd or 4th gear

Postby christruck [OP] » Jan 26 2011, 1:39pm

with lights wired to the solinoids at the top of harness plugging in at trans lights work as they should which would mean prob in trans,ugplug harness now in 3rd. i had it rebuilt, tranny shop says not there problem. unplug harness 2nd manually with shifter in 1 or 2 and 3rd in3 or D no prob with trans.all this works as it should
Original Poster
christruck
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Jan 25 2011, 7:48pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: wpb fl
Year: 1998
Make/Model: Chevrolet Silverado
Extra Info: 5.0 vortex 4x4
Group Membership:
Registered users

Re: Shift problem no 3rd or 4th gear

Postby jepics » Jan 26 2011, 9:01pm

What kind of warranty did they give you on that trans work, Chris?

Most businesses' first line of response is - "we didn't do it". Problem is they know more about what they did than you do, and they want you to prove it was something they did.

I wish I could help more, but automatic transmissions are not an area I know much about.

Let us know if there's any further developments
If you want to do what you want to do, you have to do what you have to do.
--John
5320
User avatar
jepics
Combustion on 8 pistons [L2]
Combustion on 8 pistons [L2]
Posts: 831
Topics: 51
Images: 24
Joined: Sep 02 2010, 9:16pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Rockland County NY
Year: 2009
Make/Model: GMC Sierra
Extra Info: SLE 5.3 V8 4x4 Z71
Group Membership:
How-to Authors
Registered users

Re: Shift problem no 3rd or 4th gear

Postby katjar503 » Jan 29 2011, 4:31pm

you said you can shift the trans by power and grounds, and it works right? Then you plug it in and the trans doesnt shift but the lights say that the power from the truck is right? If im folowing you right i would remove the lights and see what happens. I think you have a broken wire by conector somewhere after your test lights.
transman
katjar503
Automotive Technician
Automotive Technician
Combustion on 2 pistons [L2]
Combustion on 2 pistons [L2]
Posts: 216
Topics: 12
Images: 0
Joined: Jul 20 2010, 2:31am
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Oregon
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: hd 2500 6.0L 4X4
Group Membership:
Automotive Technicians
How-to Authors
Registered users

Re: Shift problem no 3rd or 4th gear

Postby gmctruckguy » Jan 30 2011, 6:02am

I agree with katjar503, electrical issue not in the transmission. Start checking wires for continuity, could be an intermitant somewhere in the harness where it has a bend in it since it has been moved around when transmission was R&R'd.
10638His & Hers 2012 Sierra C/C's 6.2L, 4WD, 3.73's, Airaid CAI, Diablo Predator/inTune, Magnaflow Exhaust, Piaa's, 3 1/2" RC Lift, 285 BFG T/A's, Bushwacker Flares, Tuff Country Add-a-Leaf
1063910640

User avatar
gmctruckguy
Automotive Technician
Automotive Technician
Shifting into Gear [L3]
Shifting into Gear [L3]
Posts: 1017
Topics: 24
Images: 37
Joined: Nov 28 2010, 1:38am
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Alberta
Year: 2012
Make/Model: GMC Sierra
Variant: VHO/Vortec Max
Extra Info: Max Trailering
Group Membership:
Automotive Technicians
Registered users

Return to Transmission/Drivetrain

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

problem work help right shift still gear first done think same

It is currently Nov 27 2014, 11:31am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Transmission/Drivetrain Forum
Transmission/DrivetrainTransmission and drivetrain related components. Discuss automatic and manual trans repairs and performance or talk about driveshafts or rear-ends and differentials. Diagnostics of 4-speed, 5-speed, or even 6-speed transmissions.
To create a new topic in Transmission/Drivetrain, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 6 guests