jQuery not supported.



Transmission issues with rebuilt 4L60E in 1997 Silverado

Transmission issues with rebuilt 4L60E in 1997 Silverado

Postby WHITERADO [OP] » May 04 2011, 3:52am

I just had the 4L60E rebuilt in my 1997 Silverado 2wd. Shifts great through the gears, but as soon as I let off on the gas the truck lunges or jerks like it has momentarily lost power. It tends to do it after the truck has warmed up and pretty bad around 40-50 MPH. Anyone out there have any ideas?
Original Poster
WHITERADO
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 18
Topics: 3
Images: 0
Blogs: 0
Joined: May 04 2011, 3:03am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: MELBOURNE
Year: 1997
Make/Model: Chevrolet Silverado
Group Membership:
Registered users
Related Topics  Freshly rebuilt 4l60e slipping when shifting   4l60e transmission swap   No 1st or 2nd gear on 4L60E transmission   Chevy 4L60e transmission shift at low temps.   1997 Silverado 2-4WD neutral?   Transmission Issues   Transmission Issues --- Anyone Have Ideas?   Allison Transmission Issues   Cruise control and transmission issues   transmission/transfer case issues   1995 K2500 Transmission issues? HELP!   Rebuilt trans cost??????   REBUILT MY 2004 DASH TODAY   Newly rebuilt 5.3L burning oil with less then 500 miles!? 
Transmission/Drivetrain Sponsor
Advertise Here

Re: TRANSMISSION ISSUES

Postby lzn197 » May 04 2011, 1:08pm

Does it feel like it decelerates like a vehicle with a manual transmission? And then after a second or so feel ok? That sounds like a torque converter clutch that is not unlocking.
Gordon
2004 Chevrolet Silverado Extended Cab Z71
Semi-retired Master Mechanic
User avatar
lzn197
ASE Certified
ASE Certified
4x4 Low Mode [L3]
4x4 Low Mode [L3]
Posts: 1774
Topics: 6
Images: 21
Blogs: 16
Joined: Apr 01 2010, 3:45pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Central Michigan
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: K1500 5.3L Z71 EX
Group Membership:
Automotive Technicians
Registered users

Re: Transmission issues with rebuilt 4L60E in 1997 Silverado

Postby WHITERADO [OP] » May 05 2011, 1:01am

It literally feels like someone pulls the plug for a split second, the truck lunges it is so bad. I just read 2 error codes on my truck today. 1 was an o2 sensor(bank 2 sensor 1) and the other was the camshaft position sensor. I just replaced my rotor and distributor cover last week. Guess I will be taking those back off again.
Original Poster
WHITERADO
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 18
Topics: 3
Images: 0
Blogs: 0
Joined: May 04 2011, 3:03am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: MELBOURNE
Year: 1997
Make/Model: Chevrolet Silverado
Group Membership:
Registered users

Return to Transmission/Drivetrain

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

transmission issues silverado rebuilt guess someone read cover plug vehicle week replaced feel power anyone great back today pretty again last sounds

It is currently Jul 30 2014, 8:12pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Transmission/Drivetrain Forum
Transmission/DrivetrainTransmission and drivetrain related components. Discuss automatic and manual trans repairs and performance or talk about driveshafts or rear-ends and differentials. Diagnostics of 4-speed, 5-speed, or even 6-speed transmissions.
To create a new topic in Transmission/Drivetrain, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 14 guests