jQuery not supported.



2003 Silverado 1500 2WD dying & driveshaft problems

2003 Silverado 1500 2WD dying & driveshaft problems

Postby SaifIzhar [OP] » Apr 29 2017, 6:30am

So my truck is an '03 single cab, long bed 1500 4.3L v6 2WD with 99k on the dash. I just got new tires on my truck and it drove BEAUTIFULLY the first day. The next few days I drove it and started hearing a noise like a branch snapping. I drove it around more and I started feeling shaking and a ryrhmic squeaking and light clunking. I definitely feel like it's the driveshaft but I'm not very knowledgable about trucks. Anyways, yesterday I was driving in a parking lot and I noticed the truck jittering and acting weird and very weak when I pushed the accelerator down. I thought maybe the tow/ haul mode wasn't on but the light wasn't on... so I pressed the tow haul button and the truck seemed to be working fine after that BUT the tow/ haul light on the dash never came on or off. Even when I press it now on or off I have no way of knowing if it's active. (Mind you, whenever I drive now I still notice the clank/ squeak coming from under the cab at like 20mph) so I left work tonight and got to the end of the Main Street and stopped at the light, as it turned green I accelerated BARELY and I felt it jittering and like almost backfiring and it just died in the middle of the intersection. I turned the key and it wouldn't turn over. I sat there for a minute and got out and got back in and kept on the gas and kept turning the key and it REALLY did NOT want to start but I got it running and it felt really weak again and drove it home (only 5 minutes away) but it seemed week and jittery when i first started moving and then it seemed okay to drive home. Any advice or ideas please??? I bought the truck in November with 88k on it. Recent services I've had done within the last 6k miles; oil changes, replace drivers side wheel hub assembly, new tires, new alternator, there was a short somewhere in the wiring harness that made the truck die over and over so I had that fixed (there was a language barrier over the person that fixed it so I don't know where the short was but that problem is fixed). Thank you in advance for any help.
Original Poster
SaifIzhar
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Apr 29 2017, 5:54am
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 1500 Base 4.3L 2WD
Group Membership:
Registered users

Re: 2003 Silverado 1500 2WD dying & driveshaft problems

Postby SaifIzhar [OP] » May 19 2017, 7:09pm

Update for anyone who cares, the problem with it dying was fixed by a simple tune up. I changed the plugs, wires, cap & rotor changed the air filter, cleaned the carb, added sea foam to the fuel system and everything seems to be running well. The cracking noise is still there when I change gears and take off from a stop and vibrates at all speeds but the noise coming from the suspected driveshaft doesn't come at highway speeds. Will get that fixed soon.
Original Poster
SaifIzhar
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Apr 29 2017, 5:54am
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 1500 Base 4.3L 2WD
Group Membership:
Registered users

Return to Vortec 4300 4.3L V6

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

silverado problem still wheel anyone trucks miles done bought start side first problems driveshaft dying truck back tires work help light

It is currently May 28 2017, 7:35pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 4300 4.3L V6 Forum
Vortec 4300 4.3L V6 specific.
To create a new topic in Vortec 4300 4.3L V6, click this button:
Previous topic Next topic

Who is online

Users browsing this forum: No registered users and 4 guests