jQuery not supported.



4.3 missing

4.3 missing

Postby bbr_reddragon [OP] » May 24 2012, 8:35pm

Hey guys, i am having a problem with my 4.3. when i am driving down the road and just barely giving it gas enough to pull it has a slight miss. i added some lucas oil gas system treatment to a fresh tank hoping to help clear it up but i guess im about to change all spark plugs and wires and fuel and air filter but any advise would help. Thanks
2008 Chevy Silverado 1500 ext. cab Z71 4x4 5.3
3.5 rc lift
plasti-dip wheels
plasti-dip bowties
spintech prostreet 6000 3in dual 2 1/4 out
weathertech liners
custom front plate
285/65/18 Nitto Terra Graplers
Original Poster
bbr_reddragon
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 119
Topics: 19
Images: 11
Blogs: 0
Joined: Feb 06 2012, 1:24am
Years of membership: 2 years of membership2 years of membership
Location: East TN
Year: 2008
Make/Model: Chevrolet Silverado
Extra Info: 1500 5.3 4x4
Group Membership:
Registered users

4.3 missing

Postby Machster69 » May 24 2012, 9:26pm

Do what u said and report back, keep us updated.
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7964
Topics: 104
Images: 79
Blogs: 8
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: 4.3 missing

Postby ASTE25 » May 24 2012, 9:33pm

Use genuine AC Delco parts.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10914
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

4.3 missing

Postby Camaro_Boy_07 » Aug 16 2012, 10:41pm

Check your distributor base drive gear for wear (reference pic) that was my problem! If it is worn buy a new one from summit racing for 150$ also shake your dist and listen for a clicking sound, if those conditions are present that should fix your problem. The wear on the gear causes your cam pos sensor to pick up after the pistons are at TDC to fire causing mis-fire that hardly presents itself on the ECU. Good luck
ImageUploadedByTapatalk1345153247.489069.jpg
02 Silverado 1500 4.3V6 K&N Intake, Summit Distributer, 1 1/2" Wheel Spacers, 265/75/16,
Under Construction
User avatar
Camaro_Boy_07
Firing on 2 cylinders [L1]
Firing on 2 cylinders [L1]
Posts: 22
Topics: 1
Blogs: 0
Joined: Aug 11 2012, 10:00pm
Years of membership: 2 years of membership2 years of membership
Year: 2002
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3V6 2WD
Group Membership:
Automotive Technicians
Registered users

Return to Vortec 4300 4.3L V6

Common search terms

problem missing driving parts system sound filter guess road enough help back thanks guys change fuel keep check drive

It is currently Aug 31 2014, 9:24am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 4300 4.3L V6 Forum
Vortec 4300 4.3L V6 specific.
To create a new topic in Vortec 4300 4.3L V6, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 1 guest