jQuery not supported.



Coolant system question

Coolant system question

Postby TyB [OP] » Apr 02 2012, 6:22pm

Hey. I've had my '99 Silverado for about 5 months now. My engine light has been on since i got the truck, and have traced to code to a PO420 (http://www.obd-codes.com/p0420). Which is mostly related to the catalytic converter system. I haven't experienced any problems. Only that the engine reads that it's running a little cool (87celsius). The other day the 'Low Coolant' light came on for the first time. It was about 1/4" low at most, so I topped it up. Today the light came back on and it was about an inch low. There are no leaks and I don't smell anything out of the ordinary, so I suspect there may have been air in the system, only because this hasn't happened before. I'm going to take it for another drive to see if it drops again.

I guess I don't really have a specific question about this, just maybe some opinions on what I'm looking at and what major problems could be awaiting if I don't sort this out sooner than later. I live in an area where the emissions laws are pretty lax, so if failing an emission test is my only concern, I won't panic,otherwise, any tips would be greatly appreciated. Thanks.
Original Poster
TyB
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 10
Topics: 6
Joined: Apr 02 2012, 6:10pm
Years of membership: 2 years of membership2 years of membership
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 4300 V6 4x4 Auto
Group Membership:
Registered users

Coolant system question

Postby Machster69 » Apr 02 2012, 8:06pm

Heads/gaskets
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7975
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Coolant system question

Postby Machster69 » Apr 02 2012, 8:07pm

Check the obvious first but mine ended up being such...
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7975
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Coolant system question

Postby ASTE25 » Apr 02 2012, 8:09pm

I'd say you have a coolant leak somewhere. The cooling systems on these trucks are closed, so, there should be no loss of coolant. Have the cooling system pressure tested for leaks. Now, as for the code you are getting, it may or may not be related to the coolant loss. If coolant is getting into the combustion chamber/exhaust, I guess it may be able to cause that code to show up if it damages an o2 sensor of the converters.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11074
Topics: 19
Images: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Coolant system question

Postby MaroonGmc » Apr 02 2012, 8:22pm

Could your water pump be leaking?
Recession is when your neighbor loses his job, Depression is when you lose your job,Recover is when Obama loses his.
Image
User avatar
MaroonGmc
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 14
Images: 7
Joined: Feb 24 2012, 4:35am
Years of membership: 2 years of membership2 years of membership
Location: Mobile, AL
Year: 1999
Make/Model: GMC Sierra
Extra Info: Z71
Group Membership:
Registered users

Coolant system question

Postby Machster69 » Apr 02 2012, 8:36pm

Water pump could definately be possible, and could be evaporating and not showing... A pressure test and or dye test will help with this... If its external... Be very diligent about checking the oil on next change and look for any water(internal)
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7975
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Coolant system question

Postby TyB [OP] » Apr 04 2012, 7:06pm

The coolant level hasn't dropped again since then. At one point yesterday while i was climbing a long hill, the temp actually went up to the middle range, my heater was off. after the road leveled off, the temp went back down to its usual 87c.
Original Poster
TyB
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 10
Topics: 6
Joined: Apr 02 2012, 6:10pm
Years of membership: 2 years of membership2 years of membership
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 4300 V6 4x4 Auto
Group Membership:
Registered users

Re: Coolant system question

Postby ASTE25 » Apr 05 2012, 11:11am

I just noticed your's is a 4.3 liter. Those engines are notorious for developing an intake gasket leak. If you still have problems, I'd suspect they are bad. Felpro makes a great updated gasket for them that are made of metal/rubber VS the factory's plastic/rubber configuration.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11074
Topics: 19
Images: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Return to Vortec 4300 4.3L V6

 

  • Similar topics
    Replies
    Views
    Last post
  • Coolant leak
    How to find source of leak ?
    by hotrod » Dec 02 2011, 2:44pm
    7 Replies
    3883 Views
    Last post by ASTE25 View the latest post
    Dec 03 2011, 9:26pm
  • 10 Replies
    85 Views
    Last post by SilveradoSierra.com View the latest post
    Nov 27 2014, 11:30am
  • Coolant Temp???
    New sensor, gauge still dosnt work :(
    by 604sierra » Nov 13 2013, 1:52am
    6 Replies
    471 Views
    Last post by ASTE25 View the latest post
    Nov 13 2013, 8:29pm
  • Bleeding air from radiator coolant
    by USA1 » Dec 10 2011, 1:41pm
    4 Replies
    8291 Views
    Last post by USA1 View the latest post
    Dec 11 2011, 9:23pm
  • Sludge in Coolant Reservoir Tank
    Coolant tank, reservoir, sludge
    by wrench409 » Dec 25 2013, 2:51am
    4 Replies
    660 Views
    Last post by ASTE25 View the latest post
    Dec 28 2013, 9:15pm
  • Low Coolant light every 3 motnhs
    Low coolant
    1, 2 by garciajoaquin » Mar 26 2014, 6:31pm
    10 Replies
    1008 Views
    User avatar
    Last post by CT2500HD View the latest post
    Jul 11 2014, 12:42am

Common search terms

coolant since back first system check getting today exhaust anything change light pretty trucks help thanks great still mine engine

It is currently Nov 27 2014, 11:30am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 4300 4.3L V6 Forum
Vortec 4300 4.3L V6 specific.
To create a new topic in Vortec 4300 4.3L V6, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 2 guests