jQuery not supported.



5.3 engine issues with fouled plugs

5.3 engine issues with fouled plugs

Postby Seapro210 [OP] » Jan 12 2012, 11:23pm

2010 Silverado CrewCab 5.3 / 6-speed transmission. The problem started in May 2011, starrted running rough and then check engine, service stabilitrak lights came on. Dealer said had a number 7 cylinder misfire condition and fouled plug. Replaced plug and back in business. Oct 2011 began running rough again and check engine light came on. Dealer said had a misfire and replaced all the spark plugs. Nov 2011, oil level low light comes on, Dealer says there is a tech bulletin to add oil splash shields due to the AFM relief valve misdirecting oil and allowing oil to bypass rings and burn up. Bulletin completed and now beginning to run rough yet again. From a start it surges and sometimes after turning feels like the throttle goes flat. Gas pedal in the same position, just feels like lost power. Push the gas pedal a little furthur and tach jumps up and surges forward. I think it could be a plug issue again and am wondering if I should get a tuner to disable the AFM. Any ideas?
Original Poster
Seapro210
Newbie
Newbie
Posts: 1
Topics: 1
Joined: Jan 12 2012, 10:07pm
Years of membership: 2 years of membership2 years of membership
Year: 2010
Make/Model: Chevrolet Silverado
Group Membership:
Registered users

Re: 5.3 engine issues with fouled plugs

Postby lzn197 » Jan 13 2012, 12:46am

You probably should let the dealer continue to work on it until it is fixed. If you instal a tuner, they may blame it on you (for the problems) and not fix it.
Gordon
2004 Chevrolet Silverado Extended Cab Z71
Semi-retired Master Mechanic
User avatar
lzn197
ASE Certified
ASE Certified
4x4 High Mode [L3]
4x4 High Mode [L3]
Posts: 1810
Topics: 6
Images: 22
Joined: Apr 01 2010, 3:45pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Central Michigan
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: K1500 5.3L Z71 EX
Group Membership:
Automotive Technicians
Registered users

Re: 5.3 engine issues with fouled plugs

Postby ASTE25 » Jan 13 2012, 1:35am

I'm wondering if they replaced the plugs again after they installed the splash shields.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 11011
Topics: 19
Images: 5
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Return to Vortec 5300 5.3L V8

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

engine issues again plugs fouled dealer issue start probably level power running installed work think back same problem check light lights

It is currently Oct 31 2014, 7:11am

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 5300 5.3L V8 Forum
Vortec 5300 5.3L V8 specific.
To create a new topic in Vortec 5300 5.3L V8, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 10 guests