jQuery not supported.



Low Oil Pressure Fault Issue.....

Is fine when cold, can watch the pressure drop until it faults...

Low Oil Pressure Fault Issue.....

Postby tmurph01 [OP] » Nov 06 2012, 1:29am

2009 5.3 Crew cab with AFM and 6-speed auto

Was on my way to work this morning when all of the sudden i got a warning and dinging. Looked down and I had very little oil pressure. Stopped and shut down. Checked and I had oil. Let it sit a while started it back up, hey,.. have pressure.. hmm. Started to drive and it seemed that as the engine heated up, you could watch the pressure drop until I got the warning.

Any ideas? Im thinking faulty sensor as I have oil and pressure at start-up???
2009 Silverado 1500 Z71
5.3L 6-speed auto crew cab
Original Poster
tmurph01
Firing on 7 cylinders [L1]
Firing on 7 cylinders [L1]
Posts: 76
Topics: 15
Images: 0
Joined: Sep 13 2010, 9:26pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Martinsburg, WV
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby ASTE25 » Nov 06 2012, 1:37am

I agree, check the oil pressure sensor. The are known to go bad and leak, causing a faulty reading. If in doubt, have the pressure checked with a real gauge.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby Machster69 » Nov 06 2012, 2:29am

#PIP4786: Low Oil Pressure Message Light - Inspect Valve Lifter Oil Filter - (Apr 5, 2010)
Subject: Low Oil Pressure Message/Light - Inspect Valve Lifter Oil Filter

Models: 2007 Cadillac Escalade

Built before April 1, 2006 with 6.2L L92 Engine

(These engines were built with AFM Hardware but the AFM system was disabled.)

2009 Buick Lacrosse Super, Allure Super (Canada Only)

2005-2007 Buick Rainier

2010 Chevrolet Camaro SS

2007-2010 Chevrolet Avalanche, Silverado, Suburban, Tahoe

2007-2009 Chevrolet Impala

2005-2009 Chevrolet Trailblazer

2007 Chevrolet Monte Carlo

2007-2010 GMC Sierra, Yukon

2005-2009 GMC Envoy

2007-2008 Pontiac Grand Prix

2008-2009 Pontiac G8

2005-2009 Saab 97x

With an AFM (Active Fuel Management) V8 Engine RPO: L76, L94, L99, LC9, LFA, LH6, LMG, LS4, or LY5


The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in this PI.

Condition/Concern:


Some customers may complain of a low oil pressure message/light on the dash and a technician may find a P0521 DTC in the ECM.

Recommendation/Instructions:


If this concern is encountered, follow SI diagnosis. If it indicates that the Tech 2 oil pressure parameter is low but proper oil pressure is present at the oil filter housing, inspect the Valve Lifter Oil Filter for debris/sludge that could be restricting oil flow to the oil pressure sensor before replacing any parts.
Follow the Valve Lifter Oil Filter Removal and Installation Procedure to remove the filter for inspection. If the filter is plugged, it can normally be cleaned with brake/contact cleaner and light shop air. If it cannot be cleaned for some reason, replace it using the part number listed in the parts catalog. Do not replace the complete Valve Lifter Oil Manifold just because the filter is plugged.

#452 - Valve Lifter Oil Filter

 
Screen shot 2012-11-05 at 7.28.34 PM.png
         
          
Please follow this diagnostic or repair process thoroughly and complete each step. If the condition exhibited is resolved without completing every step, the remaining steps do not need to be performed.
GM bulletins are intended for use by professional technicians, NOT a "do-it-yourselfer".  They are written to inform these technicians of conditions that may occur on some vehicles, or to provide information that could assist in the proper service of a vehicle.  Properly trained technicians have the equipment, tools, safety instructions, and know-how to do a job properly and safely.  If a condition is described, DO NOT assume that the bulletin applies to your vehicle, or that your vehicle will have that condition.  See your GM dealer for information on whether your vehicle may benefit from the information.  WE SUPPORT VOLUNTARY TECHNICIAN CERTIFICATION
You do not have the required permissions to view the files attached to this post.
Machster69
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 7966
Topics: 105
Images: 79
Joined: Feb 16 2012, 3:03pm
Years of membership: 2 years of membership2 years of membership
Location: Baton Rouge
Year: 2010
Make/Model: GMC Sierra
Extra Info: 5.3 SLE 2wd
Group Membership:
How-to Authors
SilveradoSierra Guru
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby tmurph01 [OP] » Nov 06 2012, 4:12pm

Seems like everything I am reading and talking to are also pointing to the Pressure Switch. I believe this too as the engine temp did not rise and from what it appears, I was still getting oil through the engine.

This is the sensor located on the backside of the intake, correct?
2009 Silverado 1500 Z71
5.3L 6-speed auto crew cab
Original Poster
tmurph01
Firing on 7 cylinders [L1]
Firing on 7 cylinders [L1]
Posts: 76
Topics: 15
Images: 0
Joined: Sep 13 2010, 9:26pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Martinsburg, WV
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby ASTE25 » Nov 06 2012, 4:20pm

Yes, near the drivers side valve cover.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby tmurph01 [OP] » Nov 06 2012, 4:39pm

Alright, Thanks. All local parts stores were out, so had to order one. Should be in tomorrow.
2009 Silverado 1500 Z71
5.3L 6-speed auto crew cab
Original Poster
tmurph01
Firing on 7 cylinders [L1]
Firing on 7 cylinders [L1]
Posts: 76
Topics: 15
Images: 0
Joined: Sep 13 2010, 9:26pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Martinsburg, WV
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Z71
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby cmashark » Nov 14 2012, 4:11am

Any update?
cmashark
Firing on 5 cylinders [L1]
Firing on 5 cylinders [L1]
Posts: 58
Topics: 4
Joined: Aug 21 2012, 6:49am
Years of membership: 2 years of membership2 years of membership
Location: VA Beach
Year: 2014
Make/Model: Chevrolet Silverado
Extra Info: 5.3 LT crew
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby nerijusj » Nov 23 2012, 1:55am

I had the same problem right after I bought the truck ( used, auction, can't return it, you buy it you own it type of deal ). In first 2 minutes of driving it, I got low oil press light and sounds....Crap, I thought engine was shot....Anyway, towed to garage and started with oil change. Everything was back to normal. I suggest you change the oil/filter first.
User avatar
nerijusj
Firing on 3 cylinders [L1]
Firing on 3 cylinders [L1]
Posts: 31
Topics: 3
Joined: May 08 2011, 8:17pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Boston, MA
Year: 2007
Make/Model: GMC Sierra
Extra Info: 5.3 SLT Z71 Crew
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby adamant » Jan 17 2013, 2:13pm

There are 8 posts here. What did u Guys with the problem come up with?
adamant
Firing on 3 cylinders [L1]
Firing on 3 cylinders [L1]
Posts: 30
Topics: 10
Joined: May 17 2011, 1:59pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: north east usa
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: ex cab 4x4 1500
Group Membership:
Registered users

Re: Low Oil Pressure Fault Issue.....

Postby Boucher187 » Mar 02 2013, 4:49pm

I've had same issue on my 2009 GMC 5.3 with AFM. I took to dealer and got switch replaced. Issue came back. Took to my automotive guy and he back blew the hoses with air. Issue went away for a week and came back. I took back to my local guy and did a full oil change and filter change. If it comes back again Ill need to look at the valves and see if they're faulty.
2009 GMC Sierra SLE (Crew Cab) | 5.3 L, 6-spd | 3.42 Gears | AFM
OEM Molded Mudflaps | TriFold Toneau
User avatar
Boucher187
Combustion on 2 pistons [L2]
Combustion on 2 pistons [L2]
Posts: 294
Topics: 10
Images: 3
Joined: Jun 28 2012, 2:23am
Years of membership: 2 years of membership2 years of membership
Location: North East Pennsylvania
Year: 2009
Make/Model: GMC Sierra
Extra Info: 5.3 V8 6-Speed
Group Membership:
Registered users
Next

Return to Vortec 5300 5.3L V8

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

engine back problem same light issue pressure fault first getting work thanks still right

It is currently Sep 30 2014, 7:11pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 5300 5.3L V8 Forum
Vortec 5300 5.3L V8 specific.
To create a new topic in Vortec 5300 5.3L V8, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: Java [Bad bot], Spinn3r [Bot] and 13 guests