jQuery not supported.



no oil pressure

no oil pressure

Postby heavychevy1/2 [OP] » Oct 29 2011, 1:19am

ok got a major crisis here. i bought a 1000 dollar 2000 silverado 202,000 miles 5.3 and it seems like after i changed the oil the check oil pressure light comes up on the message center. i ended up buying a new pressure sensor and breaking it so i went to the boneyard and picked out three more sensors installed two of them so far and the light still stays on and the gauge reads 0 at all times regaurdless of engine rpm. i wouldnt think that all these sensors are bad but i dont k now the test for them is there a voltage reading i should be looking at at the sensor? it also seemed to develop a tick or k nock so i thought it was the oil pump, but a friend told me if the oil pump was bad the knock would be horrendos. we ended up revving the motor hard and the noise went away we think it was a collapsed lifter that just filled back up with oil. i have a spare instrument cluster that i swappped into this truck to see if the gauge was bad and the original problem still persisted no pressure ive ran it at idle multiple times since and it hasnt seized up yet. the motor seems hard to turn over my hand compared to my parts truck which is identical in every way so im not sure what the problem is. a lot of people on the internet are saying that the problem is with the oil filter i bought a fram filter ive used these on many vehicles over the years and never had a problem. but id heard something about they dont have a antidrain back valve or they collapse internally. had heard that maybe changing the oil knocked something loose inside the engine and blocked a passage way for oil but i have no way of testing this. ive spent multiple hours searching the internet for answers and help from anyone would be great thanks in advance
Original Poster
heavychevy1/2
Firing on 8 cylinders [L1]
Firing on 8 cylinders [L1]
Posts: 89
Topics: 25
Blogs: 0
Joined: Sep 21 2011, 2:20pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Year: 2000
Make/Model: Chevrolet Silverado
Extra Info: 1500 5.3 z71 4wd 3 d
Group Membership:
Registered users
Related Topics  oil cooler line failed. oil everywhere low oil pressure.   Changed oil sending Unit. oil pressure gauge pegged on high   Low oil pressure reading, too much oil, seized at crank   No Oil Pressure   Oil Pressure   oil pressure   Oil Pressure   Oil pressure   Fluxuating Oil Pressure   Oil pressure concerns   Low oil pressure   Oil Pressure cannot figure it out   Oil Pressure Issues   Oil Pressure Sensor 
Vortec 5300 5.3L V8 Sponsor
Advertise Here

no oil pressure

Postby 1stsilverado » Oct 29 2011, 1:32am

I would find a mechanical oil gauge and go straight off the motor just to double check oil pressure.
1stsilverado
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 130
Topics: 4
Blogs: 0
Joined: Sep 20 2011, 6:06pm
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Algonquin IL
Year: 2011
Make/Model: Chevrolet Silverado
Extra Info: Lt 1500 4X4 5.3L
Group Membership:
Registered users

Re: no oil pressure

Postby ASTE25 » Oct 29 2011, 1:59am

Yes, I would do that as well, and I would refrain from revving the engine up really fast until I verified that it has good oil pressure. It sounds to me like you got the truck for a steal because the person selling it knew the engine had low oil pressure. They may have put some really thick oil (gear lube) in it to bring the pressure up. When you changed the oil you used regular weight oil and the oil pressure problem appeared.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: no oil pressure

Postby 6Sixathome » Oct 29 2011, 2:17am

A 2000 for $1000.00, that's a steal even if it did'nt have an engine, unless the body is trashed. I'd be careful not to spend too much $$ because you could go to the boneyard and get another LS engine. JMO
Image Bilstein 5100's, Signal mirrors, ADVENT OGM1, CS-GMTR1B rear view camera,
BBP tuned, AIRAID Jr. with SynthaMax Dry Filter, RX Catch Can, 2014 SIERRA 18" Z71 wheels
User avatar
6Sixathome
Shifting into Fourth Gear [L3]
Shifting into Fourth Gear [L3]
Posts: 1431
Topics: 58
Images: 6
Blogs: 0
Joined: Jul 14 2011, 12:45am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Indiana
Year: 2008
Make/Model: GMC Sierra
Extra Info: CC 1500 5.3 V8 Z71
Group Membership:
How-to Authors
Registered users

Re: no oil pressure

Postby adams99z71 » Oct 29 2011, 3:24am

dont start it again till your sure you have oil pressure ( worst case take a valve cover off and turn the engine over a few times to see oil spray). i worked with a guy who forgot to fill a car up with oil after a oil change(yeah i know lol) and he said the the customer got 3blocks down the road before the engine .... disappeared. lol. i'd put my money on your problem being electrical. if you have a multi meter probe the sensor with the engine off then with the engine on, look for a change of ohms. that should at least tell you if the sensors bad or you have no oil pressure.
nbs99 z71 325ci v8, stock 4wheel disc brakes, no cats, flow master classic 40 series, rhino line, custom fog lights, cb, bully dog tunner, 4:10 locker, airbag load leveling, 205,000miles.
User avatar
adams99z71
Armed Forces
Armed Forces
Combustion on 6 pistons [L2]
Combustion on 6 pistons [L2]
Posts: 625
Topics: 30
Images: 0
Blogs: 2
Joined: Nov 27 2010, 6:28am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: san diego
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 325ci Z71 ext cab LS
Group Membership:
Automotive Technicians
Registered users
Servicemen

Re: no oil pressure

Postby ASTE25 » Oct 29 2011, 4:26am

It could be electrical, but I wouldn't count on it. With the lifter noise associated with the loss of pressure on the gauge I'd assume the worst untill you can get a manual gauge and check it. Whoever sold the truck sold it that low for a reason. It would be a heck of a coincidence that the gauge decided to go bad right when you cahnged the oil and filter.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: no oil pressure

Postby SilverSurfer » Oct 29 2011, 5:11am

Putting a mechanical gauge on it is the way to go. Having said that, since you tried multiple sensors and even another cluster I'd just put a pump in it. You said the lifter noise went away after revving it hard... indicates weak fuel pump or oil galley blockage. Also, you said, the motor cranks harder by hand than your junkyard motor.

At this point I would put an oil pump in, degunk the motor, change the oil (again, you have to with degunk) and see where you're at. Hard revving could have damaged the engine, but you won't know until you put in the new pump.
Image
User avatar
SilverSurfer
Staff Member
Staff Member
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 2354
Topics: 45
Images: 82
Blogs: 3
Joined: Jun 27 2011, 1:29am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Phoenix, AZ
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 5.3L Auto 2wd Posi
Group Membership:
Automotive Technicians
Global moderators
Registered users
Servicemen

Re: no oil pressure

Postby ASTE25 » Oct 29 2011, 5:52am

It's probably got some worn bearings as well, maybe even scored pretty bad by now. I'd probably pull the pan and check them as well. That way you can also really clean the gunk out of the pan and also check the pickup screen for gunk obstructing it. I have the feeling this problem did not just start, so it may be worth checking it real good before dumping money in just an oil pump.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: no oil pressure

Postby adams99z71 » Oct 29 2011, 6:17am

i wouldn't put to much into the lifter noise. the early 5.3's are known for lifter noise, mines had a tick tick tick since i got her 102,000 miles ago. pull the oil drain plug its got a magnet on it, you get chunks then you know if not buy a multi-meter.
nbs99 z71 325ci v8, stock 4wheel disc brakes, no cats, flow master classic 40 series, rhino line, custom fog lights, cb, bully dog tunner, 4:10 locker, airbag load leveling, 205,000miles.
User avatar
adams99z71
Armed Forces
Armed Forces
Combustion on 6 pistons [L2]
Combustion on 6 pistons [L2]
Posts: 625
Topics: 30
Images: 0
Blogs: 2
Joined: Nov 27 2010, 6:28am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: san diego
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 325ci Z71 ext cab LS
Group Membership:
Automotive Technicians
Registered users
Servicemen

Re: no oil pressure

Postby ASTE25 » Oct 29 2011, 7:00am

If the only symptom was the lifter tick I'd agree with you. However, he said it showed good oil pressure until he changed the oil and filter. Taking all things he stated into consideration, his best bet is to use a mechanical gauge to determine if it actually has oil pressure. It's a relatively safe and inexpensive test (assuming you have or can borrow a gauge). You can still have damaged bearings due to low oil pressure and not have "chunks" of metal present on the drain magnet. The safest bet is to go ahead and check the oil pressure, then go from there if it's good. If I am wrong then the worst he is out is some time and a little effort. But, he will have peace of mind if he knows his oil pressure is good.
Jordan
2013 Blue Granite Metalic Silverado 2500HD Z71 4X4 extended cab regular bed
6.6L Duramax/Allison 6 speed
Line-X premium over the rail (black)
User avatar
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10933
Topics: 19
Images: 21
Blogs: 0
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2013
Make/Model: Chevrolet Silverado
Extra Info: 2500HD Z-71
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users
Next

Return to Vortec 5300 5.3L V8

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

engine problem check miles still pressure light installed anyone thanks great think right back help

It is currently Sep 20 2014, 6:59pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 5300 5.3L V8 Forum
Vortec 5300 5.3L V8 specific.
To create a new topic in Vortec 5300 5.3L V8, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 19 guests