jQuery not supported.



o2 sensor fuse keeps blowing

o2 sensor fuse keeps blowing

Postby tizzfishin [OP] » Apr 12 2011, 2:29am

My 06 z71 keeps blowing one the the two fuses for the o2 sensors. Sometimes it will last for a few days or up to a month. Anyone else have this issue?
Original Poster
tizzfishin
Newbie
Newbie
Posts: 3
Topics: 1
Blogs: 0
Joined: Apr 12 2011, 2:18am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Tustin Ca
Year: 2006
Make/Model: Chevrolet Silverado
Extra Info: z71
Group Membership:
Registered users
Related Topics  6.5 Diesel blowing white smoke   MAF Sensor   knock sensor   MAF sensor   O2 sensor codes   CHanging O2 Sensor   Knock sensor   2002 knock sensor   maf sensor question   Problems after sensor change   Oil Pressure Sensor   Do I have an alcohol/ethanol % sensor   Knock Sensor Problem   Oxygen sensor brand? Best source? All 4 or just 2? 
Vortec 5300 5.3L V8 Sponsor
Advertise Here

Re: o2 sensor fuse keeps blowing

Postby lzn197 » Apr 12 2011, 12:23pm

Never have and I am assuming that fuse only powers the oxygen sensor. Maybe a shorted sensor?
Gordon
2004 Chevrolet Silverado Extended Cab Z71
Semi-retired Master Mechanic
User avatar
lzn197
ASE Certified
ASE Certified
4x4 Low Mode [L3]
4x4 Low Mode [L3]
Posts: 1787
Topics: 6
Images: 21
Blogs: 16
Joined: Apr 01 2010, 3:45pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Central Michigan
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: K1500 5.3L Z71 EX
Group Membership:
Automotive Technicians
Registered users

Re: o2 sensor fuse keeps blowing

Postby rdss » Apr 12 2011, 1:51pm

I agree with Izn197, sounds like a faulty sensor or wiring.
2010 GMC Sierra 1500 SLT Crewcab:
K&N Aircharger
Blastin Bob's muffler back w/ Magnaflow muffler
BedRug BedTred
Extang Revolution Tonneau
Diablo Sport inTune....DiabLew tuned!
Black Rampage sidesteps.
User avatar
rdss
Armed Forces
Armed Forces
Shifting into Fifth Gear [L3]
Shifting into Fifth Gear [L3]
Posts: 1590
Topics: 17
Images: 0
Blogs: 0
Joined: Nov 13 2010, 1:46am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Fl
Year: 2010
Make/Model: GMC Sierra
Extra Info: SLT 1500 CC 5.3
Group Membership:
Registered users
Servicemen

Re: o2 sensor fuse keeps blowing

Postby tizzfishin [OP] » Apr 14 2011, 2:45am

Update: I bought code reader and found the following codes. P0036, p0056, p0141, p0161. After putting a new fuse in and checking all the harnesses to the o2 sensors the light stayed off for a couple trips and then came back when starting it this afternoon. Seems like it blows the fuse at startup.
Original Poster
tizzfishin
Newbie
Newbie
Posts: 3
Topics: 1
Blogs: 0
Joined: Apr 12 2011, 2:18am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Tustin Ca
Year: 2006
Make/Model: Chevrolet Silverado
Extra Info: z71
Group Membership:
Registered users

Re: o2 sensor fuse keeps blowing

Postby lzn197 » Apr 14 2011, 12:10pm

That is because that is when your Oxygen sensor heaters work. At start up!
Gordon
2004 Chevrolet Silverado Extended Cab Z71
Semi-retired Master Mechanic
User avatar
lzn197
ASE Certified
ASE Certified
4x4 Low Mode [L3]
4x4 Low Mode [L3]
Posts: 1787
Topics: 6
Images: 21
Blogs: 16
Joined: Apr 01 2010, 3:45pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Central Michigan
Year: 2004
Make/Model: Chevrolet Silverado
Extra Info: K1500 5.3L Z71 EX
Group Membership:
Automotive Technicians
Registered users

Re: o2 sensor fuse keeps blowing

Postby chewbacca » Apr 15 2011, 12:35am

you need to check wiring over your front propshaft, more than likely it is hanging down from top of trans to driver side of frame too low and is making contact with your front propshaft, that is why fuse is blowing intermitanly! Hope this helps, Good luck with repair.
chewbacca
Newbie
Newbie
Posts: 1
Images: 0
Blogs: 0
Joined: Apr 15 2011, 12:25am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: usa
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: 5.3 stepside
Group Membership:
Registered users

Return to Vortec 5300 5.3L V8

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

sensor blowing keeps fuse sounds issue came hope luck last couple seems check front work back anyone light bought side start

It is currently Sep 19 2014, 4:50pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 5300 5.3L V8 Forum
Vortec 5300 5.3L V8 specific.
To create a new topic in Vortec 5300 5.3L V8, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: Baiduspider [Bot] and 9 guests