jQuery not supported.



Throttle body problems....where to even start....

Throttle body problems....where to even start....

Postby Camdonite [OP] » Nov 20 2011, 10:39pm

I just returned from a road trip. Twice on my trip my CEL came on with a p0300 (multiple and random misfire). I have an Edge Evolution programmer so I am able to check the code on the fly. I clear the code and turn the truck off for a couple of minutes and it runs fine. So when I got home I checked the forums for the cause of the code and started going do the list. As I was checking over my truck I noticed my throttle body was all nasty and gummed up. So I unplugged it and used some Carb/Choke Cleaner to clean it. Yes, I made sure it was TB safe. In doing this I removed the butterfly to be better able to clean it. After cleaning it and re-installing to butterfly I bolted it back in and plugged it back in.

I then took it for a ride around the block, everything seemed normal until the throttle body started to stick. I got it home and it wouldn't drop the RPM's. So I again removed the TB and made sure it was spotless. I re-installed it, then I started my truck and my CEL came back on. I got p0102 (Mass or Volume Air Flow Circuit Low Input), p2119 (Throttle Actuator Control Throttle Body Range Performance), and p2176 (Throttle actuator control system...Idle position not learned).

After finding a re-learn procedure online, I got rid of two codes, but now I'm left with p1516 (Throttle Actuator Control (TAC) Module Throttle Actuator Position Performance), and p2119. And my TB is still sticking. Any help would be great. I despise the though of going to the dealership. Thanks!
Original Poster
Camdonite
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 16
Topics: 5
Images: 1
Joined: Oct 21 2011, 2:27am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Poplar Grove, IL
Year: 2008
Make/Model: Chevrolet Silverado
Extra Info: 1500 LTZ Crew Cab
Group Membership:
Registered users

Re: Throttle body problems....where to even start....

Postby ASTE25 » Nov 21 2011, 5:00am

(1) When you say you removed the throttle plate, did you actually take it out of the throttle body assembly? If yes, you probably did not get it put back into position correctly, causing it to stick. Personally I would not have removed it from the body itself. I would have just taken the body off and cleaned it with it still on the assembly. They are made to fit at very close tolerances. (2) It sounds like your IAC motor may be bad and needs replaced. Cleaning them usually does not work very well.
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10977
Topics: 19
Images: 5
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Re: Throttle body problems....where to even start....

Postby Camdonite [OP] » Dec 06 2011, 12:24am

Got her back up and running. Figured I would start with the throttle body, that was it. I called the dealership to get a price and they wanted $275 and $60 for the gasket. Decided to order them online and got them for $129 with overnight shipping from Rockauto.com. Got here the other night and my truck was purring like a kitten within five minutes.

Thanks for the help.
Original Poster
Camdonite
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 16
Topics: 5
Images: 1
Joined: Oct 21 2011, 2:27am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: Poplar Grove, IL
Year: 2008
Make/Model: Chevrolet Silverado
Extra Info: 1500 LTZ Crew Cab
Group Membership:
Registered users

Re: Throttle body problems....where to even start....

Postby ASTE25 » Dec 06 2011, 1:12am

Good to hear. Sounds like it wasn't as bad a repair as you had thought it would be (price wise).
Jordan
ASTE25
Shifting into Sixth Gear! [L3]
Shifting into Sixth Gear! [L3]
Posts: 10977
Topics: 19
Images: 5
Joined: Jan 03 2011, 6:37am
Years of membership: 3 years of membership3 years of membership3 years of membership
Location: New Market, Alabama
Year: 2015
Make/Model: ...Not an owner
Group Membership:
Automotive Technicians
Member Extraordinaire
Registered users

Return to Vortec 5300 5.3L V8

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

start body back throttle still help problems thanks probably again doing running great work installed check used

It is currently Oct 21 2014, 12:54pm

  • Sponsor
Login  •  Register
SHOP TALK (Live Chat)
Vortec 5300 5.3L V8 Forum
Vortec 5300 5.3L V8 specific.
To create a new topic in Vortec 5300 5.3L V8, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 12 guests