jQuery not supported.



engine stumbles when pressing on accelerator

Re: engine stumbles when pressing on accelerator

Postby chem_man » Sep 15 2020, 8:49am

After reviewing the engine parameters data, the only things that seem "strange" to me are 1) the second Long Term Fuel Trim Value for Bank 2-Sensor 2 is always 99.2%, and now for the one that is really curious to me is 2) your Intake Air Temperature does not vary enough (and yes I see you have the temperature being reported in Deg C).

I am wondering if there might be something wrong with the Intake Air Temperature (IAT) sensor. It seems like it does not indicate upward temperature changes rapidly enough, especially from a cold start.

I googled the symptoms of a bad IAT sensor, and some of the symptoms appear to match what you are experiencing, especially when the engine is cold. Here is a link - https://dutchfixmycar.net/the-symptoms- ... re-sensor/

Unfortunately, the IAF is part of the MAF sensor in your Silverado and not replaceable by itself.

It follows your observations of experiencing problems when the engine is cold in the morning, and no problems in the afternoon when the temperatures are warmer. There could be a poor connection inside the IAT sensor that shows up when it is say below 90 Deg F, but above 90 Deg F it could be making good enough connection to not cause problems.

I know the IAT is a thermister which when the temperature is low, it's resistance is high, and when the temperature increases, it's resistance decreases. It might be sending the wrong resistance to the PCM at "cold" temperatures.

Of course I could be completely wrong, but I compared the responses of your IAT and ECT vs the responses of the IAT and ECT in one of my vehicles, and your IAT values don't change as rapidly.

Good Luck!
chem_man
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 114
Joined: May 19 2012, 1:51am
Years of membership: 8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
Location: Maryland
Year: 1999
Make/Model: Chevrolet Silverado
Variant: LS
Extra Info: Ext Cab 5.3L V8 2WD
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 1:55pm

So should I replace my MAF sensor since the IAT is part of it.
I have read with it going bad wont give a p0300 code.
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby MotorEng91 » Sep 15 2020, 2:45pm

When you first started the data logging, you have engine coolant temperature of 45C=113F and intake air temperature of 36C=97F. Seems normal.

After your engine warms up and you are in closed loop, you have engine coolant temperature of 90C=194F and intake air temperature of 41C=106F. Possibly a little low on the intake air temp, but the sensor is located inside the MAF (air duct) somewhat far away from the engine itself. You will still have some engine bay heat contributing, but if your fans are working fine, I would like to say this is normal too.

About the sensor 2 fuel trim measuring 99.2%, I read this value is measuring catalytic converter efficiency and can be safely ignored. A few forums on Google about this topic, not particular to our trucks. The important ones are STFT B1&B2, LTFT B1&B2. You can ignore the ones specific to one oxygen sensor.

One more thing about the data you have logged that caught my attention and I am not sure if this is a problem or another case of unit conversion error by the scanner/ECM. You are measuring Intake Manifold Absolute Pressure at 39 to 40 kPa. I read that an engine should typically idle at 18 to 22 inches of Mercury (inHg). When you convert 40kPa to inHg, it is only 11.8 inHg. I kind of doubt that is actually the true intake manifold pressure because I think you would have more driveability concerns if that were the case
Image
2010 GMC Sierra 1500 WT
4.8, 4L60, 3.23, 275/55/20
K&N Blackhawk, Gibson dual cat-back, Diablo 93 Tune
MotorEng91
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 165
Topics: 1
Images: 2
Joined: Dec 21 2019, 9:32pm
Location: St. Louis, MO
Year: 2010
Make/Model: GMC Sierra
Variant: WT
Extra Info: 1500 4.8L 2WD
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 2:53pm

My truck has a damn fan clutcb not electric fans.. UGH
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 2:54pm

The only driven issue is when tbe truck does what it does cold and ok when warmed up.
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 2:55pm

That part is original to the truck.
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 2:59pm

Since lat July I have only gotten 3 codes P0440, P0300, and p0327.
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby MotorEng91 » Sep 15 2020, 3:03pm

Yeah, I don't think there is a problem with the fan. If there was, you would be overheating. More or less what I was saying is the engine data looks normal, except the intake manifold pressure. But I think that may just be reported in the wrong units.

I still think it sounds like a intermittent electrical problem. Somehow when the engine warms up, it gets better. Can you view more specific data about the misfires? Like a misfire counter on each cylinder
Image
2010 GMC Sierra 1500 WT
4.8, 4L60, 3.23, 275/55/20
K&N Blackhawk, Gibson dual cat-back, Diablo 93 Tune
MotorEng91
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 165
Topics: 1
Images: 2
Joined: Dec 21 2019, 9:32pm
Location: St. Louis, MO
Year: 2010
Make/Model: GMC Sierra
Variant: WT
Extra Info: 1500 4.8L 2WD
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 3:12pm

I had my scan tool on metric. Because it measured the MAF sensor readings in grams not lbs.
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users

Re: engine stumbles when pressing on accelerator

Postby robertbassin5 [OP] » Sep 15 2020, 3:13pm

No it doesn't read the misfires
Original Poster
robertbassin5
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 194
Topics: 7
Joined: Mar 14 2018, 7:06pm
Years of membership: 2 years of membership2 years of membership
Location: Texas
Year: 1999
Make/Model: Chevrolet Silverado
Extra Info: 1500 4.3 l v6
Group Membership:
Registered users
PreviousNext

Return to Engine

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

engine truck still accelerator stumbles pressing think silverado

It is currently Sep 20 2020, 5:14pm

  • Sponsor
Login  •  Register
Engine Forum
EngineThis is where all of our engine discussion and conversation takes place. Talk about engine diagnostics, adjustments, modifications, performance and care. Motor tuning and repair to gain horsepower and fuel efficiency.
To create a new topic in Engine, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 11 guests