jQuery not supported.



2017 Silverado 5.3L - Misfiring and no power under 1500 RPMs

2017 Silverado 5.3L - Misfiring and no power under 1500 RPMs

Postby Tacflame759 [OP] » Jun 29 2020, 8:50pm

Good Afternoon Everyone,

First time here, and very excited to find the Forum. Hopefully the array of talent can help me narrow down a problem.

I have a 2017 Silverado 1500 LTZ Z71, 5.3L engine. She has 115,000 miles on her, and two weeks ago, I had a P0420 Code and was told I had to replace my Catalytic Converters. I had the repairs done on Saturday (6/27/20). This included a new Y-Pipe, Catalytic Converters already installed inline on the pipe, new O2 Sensors, and Clamps. The next day I was planning a trip from Philadelphia to Columbus Ohio (475 Miles). She ran great after the repair, no hesitation, took her to the highway, she merged into highway traffic painlessly hitting 80MPH easy. Drove her home, and shut her down for the evening.

The next morning, got in to start my trip, backing out of the driveway, put her in drive, pressed on the gas, and she died. CEL was back,with a P0300 code. I finally got her to start to move, but it was a painful ordeal. Choking and popping, pumping the accelerate to get her to stay alive and moving until the engine hit 1500RPMs After she hit 1500 RPMs, it's like she clears her throat and she runs great. No CEL, no issues or hesitation, and had power. So hit the highway for a test run (15 Miles). Got her up and over 90MPH at one point with no hesitation, and probably could have pushed her more if I wasn't worried about a ticket. So I braved the trip, made it into Columbus. As long as she keeps moving, she's great. Getting her moving, the hard part.

Please, I hope the experts here can shed an idea or two on what to look at, and what could be causing this issue. The truck has had all recalls fixed (just computer software updated), last year. Long before this latest incident.
Original Poster
Tacflame759
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Jun 29 2020, 7:48pm
Location: Philadelphia
Year: 2017
Make/Model: Chevrolet Silverado
Variant: LTZ
Extra Info: 5.3L
Group Membership:
Registered users

Re: 2017 Silverado 5.3L - Misfiring and no power under 1500

Postby EaOutlaw1969 » Jul 01 2020, 5:38pm

just giving your thread a bump, I think the P0300 is a general misfire code, I would start by checking the obvious maintenance items,plugs, wires,leaking intake, compression etc. Sorry but I am not much help on new vehicles other than to suggest to follow the diagnostic flow chart for P0300 in a factory service manual and see where it takes you.
Since you had new cats installed, let the truck warm up for a 20-30 minute ride or idle then check the temperature before and after the cats with a laser temperature gun report your findings here. After a long trip like this you could have wrecked the new cats or have clogged exhaust from the old cats.
After the cat temperature test you could connect a cheap vacuum gauge to a central vac port to check for clogged exhaust ( plenty of videos online showing you how to do that test.)
Hopefully the bump will get others here to notice your thread.
User avatar
EaOutlaw1969
Combustion on 4 pistons [L2]
Combustion on 4 pistons [L2]
Posts: 424
Topics: 7
Images: 0
Joined: May 29 2020, 11:44am
Location: Florida
Year: 2015
Make/Model: GMC Sierra
Variant: LS
Extra Info: 5.3 Flex
Group Membership:
Registered users

Re: 2017 Silverado 5.3L - Misfiring and no power under 1500

Postby Tacflame759 [OP] » Jul 05 2020, 5:20pm

Thank you. I have the Truck at the Dealer, and the Tech has run a series of tests. Removed the O2 Sensors, even separated the exhaust from the manifold and tried to start it. It still ran the exact same way. There was no maintenance done to the truck other than the new Catalytic converter and y-pipe install. The dealership opened a case with GM on Friday. Hopefully tomorrow we will learn more. I need my truck back on the road, if wheels ain't turning, I'm not earning.

Thank you for your Bump, and reply.
Original Poster
Tacflame759
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Jun 29 2020, 7:48pm
Location: Philadelphia
Year: 2017
Make/Model: Chevrolet Silverado
Variant: LTZ
Extra Info: 5.3L
Group Membership:
Registered users

Re: 2017 Silverado 5.3L - Misfiring and no power under 1500

Postby EaOutlaw1969 » Jul 05 2020, 5:25pm

Good luck please let us know what they find.
User avatar
EaOutlaw1969
Combustion on 4 pistons [L2]
Combustion on 4 pistons [L2]
Posts: 424
Topics: 7
Images: 0
Joined: May 29 2020, 11:44am
Location: Florida
Year: 2015
Make/Model: GMC Sierra
Variant: LS
Extra Info: 5.3 Flex
Group Membership:
Registered users

Return to Exhaust

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

silverado truck back rpms done help power misfiring problem wheels getting first miles great think still same engine

It is currently Jul 12 2020, 5:09pm

  • Sponsor
Login  •  Register
Exhaust Forum
ExhaustTopics regarding exhaust systems beginning at the headers down the pipes and through the catalytic converter and the mufflers and exhaust tips. We can also discuss emissions, performance cat back exhausts, or any exhaust related topics.
To create a new topic in Exhaust, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 9 guests