jQuery not supported.



Speakers don't work (new speakers installed)

Speakers don't work (new speakers installed)

Postby Jaycray88 [OP] » Jul 12 2017, 4:58pm

Recently started to notice speakers going out one by one. I replaced all speakers with new aftermarket ones and everything worked well for almost a year.

I went in my truck the other day and noticed I only have tweeters. I took all speakers out and tested them one by one and they all work.

While I took speakers out I looked for loose connection or broken wires and everything is fine. ( even looked in rubber boot where wires run from cab to door panel.)

The only thing I can think of now is that there is something wrong with factory amplifier (deck/radio). Is there anyway I can test the amplifier and see if that's my issue? I don't mind replacing it, but just don't want to spend that money for it not to be the issue.

Any help would be appreciate it!
Original Poster
Jaycray88
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Jul 12 2017, 4:45pm
Years of membership: 2 years of membership2 years of membership
Location: Canada
Year: 2008
Make/Model: GMC Sierra
Group Membership:
Registered users

Re: Speakers don't work (new speakers installed)

Postby zap » Jul 13 2017, 7:47pm

Check the AC voltage on the pair. Should be the same at all corners with the the balance and fade set to neutral.


Sent from my iPhone using Tapatalk
zap
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 121
Topics: 6
Joined: Jul 20 2015, 10:08pm
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: Permian Basin
Year: 2013
Make/Model: GMC Sierra
Extra Info: 1500 5.3L 4x4
Group Membership:
Registered users

Re: Speakers don't work (new speakers installed)

Postby sudden_impulse » Jul 13 2017, 7:53pm

You can pull the radio out of the dash and hook the speakers up as close to the HU as possible to see if there are any wire breaks anywhere. If they still don't work, I would guess it's the internal amp. You can find a junkyard radio and get it flashed to your truck at a dealership for $50-75 usually.
03 Sierra Build Thread
Candied tails, Flowmaster Super 44 Dual Exhaust, 2.5" RC Level, Pocket Flares, 17x8.5 -6 American Outlaw Sheriff, LT285/70-17 Cooper ATP, PowerStop Z36 brakes, Kenwood KDC-X693
sudden_impulse
Combustion on 4 pistons [L2]
Combustion on 4 pistons [L2]
Posts: 424
Topics: 3
Joined: Jan 14 2015, 3:44am
Years of membership: 4 years of membership4 years of membership4 years of membership4 years of membership
Location: East Bethel, MN
Year: 2003
Make/Model: GMC Sierra
Extra Info: SLE 1500 Z71 4x4
Group Membership:
Registered users

Re: Speakers don't work (new speakers installed)

Postby Jaycray88 [OP] » Jul 14 2017, 12:51pm

K I'll give it a shot. I wAnted to buy aftermarket one anyways so gives me an excuse. I'll post after I changed head unit to see if that fixes problem. It's the only thing I can see that will fix it. I'm pretty confident that the wires and all good as I inspected them thoroughly.
Original Poster
Jaycray88
Newbie
Newbie
Posts: 2
Topics: 1
Joined: Jul 12 2017, 4:45pm
Years of membership: 2 years of membership2 years of membership
Location: Canada
Year: 2008
Make/Model: GMC Sierra
Group Membership:
Registered users

Return to Mobile Electronics

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

work speakers truck installed problem check thing using think help still same sent

It is currently Dec 08 2019, 12:45pm

  • Sponsor
Login  •  Register
Mobile Electronics Forum
Mobile ElectronicsTalk about audio systems and mobile video, navigation systems and GPS, car alarms and security systems. Discuss auto competition with amplifiers, subwoofers, sound quality, and SPL. Entertain with satellite radio, CB radio, DVD players, and game consoles.
To create a new topic in Mobile Electronics, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 3 guests