Chevy Silverado and GMC Sierra Forum banner
1 - 20 of 45 Posts

· Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
hey guys I have a 1993 Silverado 5.7 350 throttle body injected automatic truck. the problem is that it dies while your driving it down the road completely random it seems. when it dies there is no rough running process before or after and it starts right back up after turning the key off then back on. I have replaced : coil, plugs and wires, complete distributor, timing chain, intake manifold gaskets, EGR ,vacuum hoses everywhere , fuel pump ,fuel tank ,fuel filter. I have also installed a rebuild kit on the throttle body and rebuilt the injectors as well. I have had this truck for some time and am a heavy equipment mechanic by trade. I was told by a friend that it may be clogged exhaust because it smells like its running rich and has no check engine light its pretty random when it does die. any help would greatly be appreciated and I will answer any other questions you have as fast as I can thanks!
 

· Registered
Joined
·
1,852 Posts
While it's idling smack the PCM with a rubber mallet, if it stalls replace the PCM. Believe it or not, this was in a service bulletin from GM. :lol:

One thing to look at is the main PCM ground on the thermostat housing, common fault on that year.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
All of the fuel system was gone through very recent this week on the tank and pump and filter, September was when I done the top end rebuilt. the intake and up, I rebuilt everything however I didn't like how the injectors went together though very tight to me but seem to be spraying correctly and evenly with my reference being a friends tbi truck that runs good and I still get 11 to 13 mpg. the PCM was replaced by me shortly after I bought the truck I replaced it with a remanned one from orilleys a few years ago that could be the problem. the ignition is the original one very wore out you can pull the key right out in the on position that may be the problem it does have tilt steering as well nearly 400k miles on it. it does seem to be running very rich still even warmed up im not sure it there is a enrichment cycle on tbi engines or not. it darn near makes your eyes water standing by the tailgate it has factory exhaust manifold and a 20 series one inlet into two outlet duels out the back all 3 inch pipe been on the truck since I got it factory o2 sensors still there no cats.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
all of the things I have replaced have been since July nothing older. the truck has been nickel and diming me to death since. the engine has 150psi + or - 5psi between cylinders on all of them. and this issue started a little over a week ago and that caused me to replace the fuel pump cause In my experience that's what I thought it was after pulling the factory pump out of the tank and seeing how badly rusted it was I replaced the tank as well as the filter and only after that I posted on here to come up with a better approach.
 

· Banned
Joined
·
2,174 Posts
That's pretty good compression for that that engine. You may trace the wire to the fuel pump as well. It may even me shorting or pinching the wire. Maybe something else shorting. Does it die immediately? Could be the alternator. May disconnect it at the alternator and drive it in the daytime and see if it happens? Make sure to disconnect the battery end or insulate it well.
 

· Registered
Joined
·
1,007 Posts
Sounds so familiar to my 1991 K5 Blazer gremlin...here's my swaptronics list:



And this troubled me so much from Aug 2014 til this year...that my Blazer hasn't been driven on the road since April 2016...I lost the trust factor in driving it. :(

Sent from my XT1585 using Tapatalk
 

· Registered
Joined
·
15 Posts
Discussion Starter · #10 ·
I just checked the timing on the truck its at 0 degrees with the electronic advanced unplugged and 33 degrees when plugged at 800ish rpm. it still dies randomly when it does the spark is shut off from the coil so I just now went got a second new coil just for fun and replaced the coil again still dies at random about to go pick up a new ECM I had o'rilleys pull up my account when I replaced the ECM it was in July of 2014 so ill just swap it out and see its a remanufactured ECM anyways so u never can tell. im getting very frustrated with this truck.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #16 ·
that's what I have been doing for the past couple hours here at the shop seems to be running longer intervals the hotter it gets just idling when revving the truck it dies more often even when my foots in the throttle I have been unplugging connectors and chasing wires all morning
 

· Registered
Joined
·
2,249 Posts
is there a way to tell if it's an ignition shut off vs fuel shutoff. I don't know, I'm just throwing things out there. I'm sure it happens so fast it's impossible to tell. But you say once it dies it will immediately start right back up.
 

· Registered
Joined
·
15 Posts
Discussion Starter · #18 ·
yes its hard to tell if its fuel or ignition it shuts off soo fast and it starts right back up so easily like theres nothing wrong with it the only thing that stays odd all the time is that is smells very rich all the time
 

· Registered
Joined
·
1,007 Posts
Yep, I'm right there with you. Same issue and same attempts to fix an problem that doesn't want to be fixed. It just wants to torment me...

Mine is so sporadic you never know when it'll show its ugly self. :(

Sent from my XT1585 using Tapatalk
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top