Chevy Silverado and GMC Sierra Forum banner

2008 LY6 swap hanging idle

1474 Views 2 Replies 2 Participants Last post by  Nick699
I recently bought a 2008 GMC Sierra ext cab that was previously a 5.3 but had a ly6 out of a 2008 2500 van swapped into it. The truck has ran great until recently. It threw the P0121 code but still ran fine but I decided to clean the throttle body.

I removed the throttle body completely while the battery was disconnected and then reassembled. I assumed the ecm just needed to relearn the idle and tps but after several days of driving and eventually going to a shop and having it reset im still having issues. I have tried a brand new throttle body and checked for vacuum leaks but neither helped. The truck was supposedly tuned as I assumed it would have had to be for the swap. Is it possible I will have to have the truck retuned? The truck will idle down to 600-700 RPMs when to a complete stop but when you start rolling it will pull itself and stick around 1000 rpms until you come to a complete stop for several seconds, also if you rev the truck in park or neutral it will hang up and not drop down. The truck is showing no codes, but not sure what codes it would show or not show since I do not know what all has been turned off with the tune. The only thing I can think of that might be the issue is either the tune or possibly the pedal sensor?

Any ideas would be great right now I am stumped. (I am having similiar issues as this guy with his trailblazer, including the rpm jump when slowing down)
1 - 3 of 3 Posts
given the fact that the ecm is now operating on an edited calibration I would start there. If it's not kicking codes than the Ecm thinks it's normal operation. So normal operation needs to be corrected. Idle speed vs wheel speed relative to trans gear needs corrected. In short find a good tuner and have this corrected.
Finally got it running right. After everything it still just needed the idle reset. The only way we could get it to reset is with a hp tuner. We previously tried to use the matco computer but it would never complete. Not sure if this is a common issue with the matco scanner/computer tool but if anyone has this issue try using an official tech 2 gm tool or resetting it with hptuner.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.