Chevy Silverado and GMC Sierra Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2011 sierra, about a month ago my vents stopped blowing any air from the dash. When I change from face to feet etc... I get nothing, but it will blow the defrost like a monster and is very warm. I tried going back and forth from cold to hot and it works on the defrost again but nowhere else.
I located the one actuator on the drivers side but haven't done much else with it. Can anyone fill me in a little if they've had a similar problem and let me know what they've discovered?
 

· Registered
Joined
·
287 Posts
Lot of views, no replies? I'll jump in, but without a lot of help. My '05 DMAX, when blend doors/actuators started acting up, I could turn the truck off and back on, they would operate correctly, for a while or for days. There was a way to re-set the head by removing AC fuse under the hood for about 5 minutes, re-install fuse, turn key to 'on' position and head unit would go through a re-programming mode. This would only help for several days. In my case, it was all blend doors with problem, had them replaced with no further issues before trading it, yours sounds like it may be in the unit head.
Anyone else have ideas other than having a dealer check it out?
 

· Registered
Joined
·
196 Posts
try pulling the fuse as mentioned above, or pull the battery cable for about 5 mins. I had a similar issue last winter and pulling the battery cable reset the system and haven't had a problem since...knock on wood.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top