Chevy Silverado and GMC Sierra Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
176 Posts
Discussion Starter · #1 ·
2000 4.8 engine and harness. (Swap for my Beretta) From what I've been able to search, it looks like the those circuits power the injectors and coils, odd and even. As soon as the key switch is on, both fuses pop. I looked at the wiring and it all looks fine. I measured resistance from the fuse terminal to ground and got 450ohms with the fuse out on both
Out of curiosity, I did the same thing with my 2001 8.1 and saw 1600ohms on both with the fuse out.
It seems to me like they should be the same.
Any thoughts?
 

·
Registered
Joined
·
176 Posts
Discussion Starter · #2 ·
New info:
I unplugged all the injectors and coil packs and plugged them in one by one with the key on to see when the fuse blew. Both both banks/circuits act identical.
Injectors are all fine.
All the coils individually are fine.
But the fuse blows when the second coil on either bank is plugged in, regardless of order.
WTF?
 

·
Registered
Joined
·
176 Posts
Discussion Starter · #3 ·
I'm an idiot. In case anyone else has this problem (which you probably wont) here's the answer.
Hook up the red cable to B+ and the black one to B-. haha
The way I had my the PCM and fuse block stacked on top of the battery I couldn't see that I had the terminals backwards. Well, easy fix!
 

·
Registered
2000 K2500 Crew 5.7L/4L80E;05RadoL59/4L60EZ71;07RadoL76/4L70E4x4
Joined
·
58 Posts
Dope intake and fuel rail setup
 
1 - 6 of 6 Posts
Top