Chevy Silverado and GMC Sierra Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
This has happened numerous times with my wife but only once for me and I hooked up the battery charger and it started right up. But sometimes you'll just hear "click" and it won't start. Having had GM's in the past I was thinking maybe starter solenoid? Any other thoughts or ideas? :?:
 

·
Premium Member
Joined
·
3,170 Posts
If it is the solenoid... its built on to the starter as a non-replaceable part . Gotta replace the whole starter.

Have you had the battery tested... in this cold weather a cell could have died or something.

sent from my Verizon Wireless Galaxy SIII
 

·
Registered
Joined
·
102 Posts
What's happened on more that one vehicle for me, as well as in the auto shop. That the battery will only have somewhere around 10.some volts, enough to turn everything on, but not enough to crank the starter.

Usually the problem was a cell in the battery going dead, or a parastic drain problem. Where something doesnt shut off when it should.

Sent from AutoGuide.com App
 

·
Registered
Joined
·
751 Posts
I would also check the battery and the cables. I've had a truck not start sometimes but the batter would always test good and it was just the cables were to corroded, even though it didn't look that way.
 

·
Registered
Joined
·
16,624 Posts
Yep, usually when you get the click....click....click, it is caused by the battery not supplying enough power to the starter. It could be the battery going bad, the battery not having a full charge (not recharging as you drive) or a problem getting the power to the starter (bad cables).
 

·
Registered
Joined
·
210 Posts
Same thing, had battery tested it was dead.

Replaced battery in March, have had ZERO issues since then.

It's the battery don't go replacing parts - just replace the battery IMO.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Well I guess only time will tell but I took the old battery to be checked and it was completely dead despite truck running earlier that day (had to jump it). $150.00 battery later and everything so far is fine. Will post more if problem continues. Thanks for the help and ideas everyone.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top