Chevy Silverado and GMC Sierra Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
Not quite shure what topic to post this in,Im real shure of it being electrical so..I have a 2010 Silverado 5.3 6l80 with 21k miles.After a longer drive I get this high pitch electrical sound that I can hear inside the truck,but with window down its very loud,It happens at part throttle(cruzing any speed as long as moving)Its intermittent,and goes away at stop,or full throttle.Does not do it on short trips.....
Some things to consider is since the 285's and Diablo Intune my truck has never shifted right,it shifts to soon causeing the exhaust to rattle like lugging a standard shift,possibly torque converter problems?..COULD I have oil out of K&N filter on something to cause this problem.
Again its 100% an electrical noise
I have released the vin and all programming is back to stock,didnt change
Please any help,Ideas of what I look for?
 

·
Registered
Joined
·
4,971 Posts
First to fix your tune, turn off dod or AFM have Lew change 1-2 shifts out to 2200 rpm. Keeps from hunting gears. Electrical sound like a buzz when pressing gas? Electrical induced noise any aftermarket stereo equip? Check alternator that it's not on the fritz. Make sure battery cables are clean and tight.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
My 1st thought was the Amp,But realized its comeing from engine bay,Very loud outside.I would go along with the alternator as something to consider,Its not a buzz,its a high pitched sound,somewhat like a loud fuel pump sound,only louder,...Any speed(neutral,123456)BAD is it only does it moving,its hard to check anything when it don't do it while setting still,I tried to throttle in park,power braking.will not do it setting still...Ive even thought of a wheelspeed sensor going on the fritz...Hopeing to do some checking Saturday,just don't really have a clue of what all to consider
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #4 ·
My opinion of the Intune,its an expensive devise to turn off DOD,correct tire size.My truck performs better stock tune with dod turned off.feels like more torque than 87 octane,Diablo tune,and every time ive tried tcm tune I chose hard shift,and even after 1000 miles of learning, it still shift so hard at full throttle it sounded like (bang)breaking stuff,I have tried modifiy stock TCM,uping shift RPM,and found the only way to keep it from lugging is to use M 4 when not interstate driving...I released the vin and removed Intune for the simple reason,I believe it created my noise....Your right though DOD really needs turned back off :)
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #5 ·
I guess I shouldn't be harsh on Intune without fully explainining...Ive tried to narrow my noise down to things ive noticed...I thought the torque converter maybe because the lugging,that didn't do it a yr ago when I 1st got the 285's..2nd I thought K&N filter oil on something because of my truck never has learned a cold start,It starts,falls flat,sometimes lope like it has a cam for a few seconds(every cold start)...I believe whatever my noise is will fix both,just my guess
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top