Chevy Silverado and GMC Sierra Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2004 silverado 2500hd 4x4 6.0
The check engine light flashes only when idling, some times. some times it idles smooth other times rough. engine can warm or cold it doesnt matter
what i have done so far
changed coils, plugs, wires, intake gaskets, fuel system flush, cleaned mass air flow sensor and throttle body
i have done a smoke test and it showed nothing unusual
ive been told it was intake gaskets, cam lobs worn off or carbon built up on heads
cant believe it would a cam or carbon. it would idle rough all the time, correct?
any ideas? thanks
 

· Member Extraordinaire, Servicemen, How-To Author
Joined
·
16,428 Posts
I would have guessed it was a vacuum leak somewhere but your smoke test should have detected one if it exists. If someone mentioned an intake gasket, it is likely they were alluding to a vacuum leak which a smoke test should detect. The other area I would have suggested is to concentrate on is the throttle body before I would start looking at engine internals. Did the throttle body swap make a difference?
How many miles on the truck by the way?
 

· Member Extraordinaire, Servicemen, How-To Author
Joined
·
16,428 Posts
19trax95 said:
Codes? If the light came on there should be codes stored. That may at least help narrow it down
That's cheating. If you haven't thrown at least $100 in parts and two afternoons worth of work into it, then you are not allowed to scan the codes.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
it has 184000 miles the only code is po 300 for random misfire
I havent changed the throttle body only cleaned it
all this started back in january i figure sooner or later it will show me what needs fixing
I have taken very good care of truck it gets used but not abused
 

· Supr Moderator AutoTech SS-Guru Mbr Extraordinaire
2015 High Country Duramax
Joined
·
19,431 Posts
Good luck with that code.

I have the same one on my 01, but it only happens sometimes at highway speeds and there is no signs of it other than the light. I don't hear, feel, or notice anything.

I am not even bothering to try and track it down anymore since it's so sporadic. But it sounds like yours is a tad more consistent. At least it's at idle so you can try stuff to track it down with ease.

I've hooked my scan tool up to mine and it's cylinder 5, 6, 7, and 8 that have the misfire counts higher when it happens.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top