Chevy Silverado and GMC Sierra Forum banner
1 - 20 of 47 Posts

· Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
I have a whole 190 miles on my 3.0 and a check engine light came on and the screen states: Service Emission System - See owners manual. Then flashes "In 175 miles speed will be limited to 65 mph.

Nothing in the owners manual and what they gave me as a manual is a booklet that states on the outside "Silverado 1500 Essential Operating and Safety Information". No "owners manual"

Looked up the 3.0 duramax manual on line and couldn't find anything there.

Any help would be appreciated.
 

· SilveradoSierra Guru
2004 Sierra 3500 6.0L, auto, extended cab, cab&chassis, upgraded to 4wd
Joined
·
3,118 Posts
you can download the owners manual directly from chev's website, both it and the diesel supplement.

have you just done a bunch of really short trips? maybe the regen system is having problems completing it's cycle?
 

· Registered
Joined
·
29 Posts
I have a whole 190 miles on my 3.0 and a check engine light came on and the screen states: Service Emission System - See owners manual. Then flashes "In 175 miles speed will be limited to 65 mph.

Nothing in the owners manual and what they gave me as a manual is a booklet that states on the outside "Silverado 1500 Essential Operating and Safety Information". No "owners manual"

Looked up the 3.0 duramax manual on line and couldn't find anything there.

Any help would be appreciated.
Take it to the dealer, mine did the same. Software update.
 

· Registered
Joined
·
121 Posts
Discussion Starter · #5 ·
Thanks for the suggestions. I have been doing some short trips with it, so that could be the problem.

Will run it into the dealer today and see what they can find.
 

· Registered
Joined
·
121 Posts
Discussion Starter · #8 ·
Well just back from the dealer, WITHOUT MY TRUCK! They ran a diagnostic and it state the number 2 DEF injector has failed. They also stated it's the second LZ0 with the same problem.
And of course the really bad news, 3-4 weeks to get a new injector!!!!!!!
Sure not feeling all warm and fuzzy about this.
 

· Registered
2023 Sierra LZ0
Joined
·
118 Posts
Well just back from the dealer, WITHOUT MY TRUCK! They ran a diagnostic and it state the number 2 DEF injector has failed. They also stated it's the second LZ0 with the same problem.
And of course the really bad news, 3-4 weeks to get a new injector!!!!!!!
Sure not feeling all warm and fuzzy about this.
Man I hate to hear that already. Sorry bud, what a way to take the wind out of your sail. I was going to come in and say I started the day off at 70 miles and just got home at 497 miles and damn I love this truck! Guess I'll keep that to myself. 😎
 

· Registered
Joined
·
121 Posts
Discussion Starter · #10 ·
Man I hate to hear that already. Sorry bud, what a way to take the wind out of your sail. I was going to come in and say I started the day off at 70 miles and just got home at 497 miles and damn I love this truck! Guess I'll keep that to myself. 😎
Hey no worries and super glad you love the truck, I know I love mine. See below.
 

· Registered
Joined
·
121 Posts
Discussion Starter · #11 ·
Well happy days are here again, I got my truck back last night. They said they took the injector out and cleaned it and reinstalled it and problem solved. They want to keep the repair tag open and call them Monday to give them a report and make sure they got the problem solved. I'll keep my fingers crossed. I will say they get an A+ for busting their ass to get the problem solved.
I'll keep you posted.
I plan on putting some highway miles on it this weekend.
 

· Registered
2023 GMC SIERRA SLT, 3.0 LZ0
Joined
·
16 Posts
Well happy days are here again, I got my truck back last night. They said they took the injector out and cleaned it and reinstalled it and problem solved. They want to keep the repair tag open and call them Monday to give them a report and make sure they got the problem solved. I'll keep my fingers crossed. I will say they get an A+ for busting their ass to get the problem solved.
I'll keep you posted.
I plan on putting some highway miles on it this weekend.
Curious about where your truck was made. Look at your VIN # if it starts with a 1 it was made in the US; a 3 shows that it was made in Mexico. Mine has the 3 code. Although all of the engines and transmissions are manufactured in the US.
 

· Registered
Joined
·
121 Posts
Discussion Starter · #15 ·
I’ve got about 1000 miles on mine. Trip home from the dealer was 250 miles. The next 4 trips were 125 miles each. My shortest trip is on the order of 35 miles one way cause I live in the middle of nowhere. That’s one of the reasons I bought this LZ0.
I only have about 300 miles on mine. The fix seems to be working not check engine light.
 

· Registered
2023 Sierra LZ0
Joined
·
118 Posts
Mexico for mine as well.


I have a paint issue on my hood which I'm disappointed about but hopefully it will get resolved properly.


it's below the clear and they all look like finger prints
Cloud Water Sky World Natural landscape



Middle left and middle to the right.
Atmosphere Cloud Liquid Sky Automotive lighting


center of the pic just below the seam between the quarter panel and the hood.
Automotive parking light Automotive tail & brake light Automotive lighting Hood Motor vehicle
 
  • Wow
Reactions: Red *

· Registered
Joined
·
37 Posts
add me to the list, just threw a check engine light comin home from work approx 1200 miles, the chevy app says "service emissions, I did not get the in truck message tho, unless I missed it. going to run my obd scan see what it says and call dealer. Also had a minor paint error at all top left of the rear cab looks like a paint chip or paint missed no big deal but makes me think if it was me or not cant see how it could have been
 

· Registered
Joined
·
121 Posts
Discussion Starter · #18 ·
SFLTruck, that is a major paint issue and so much for quality control. They show be able to fix that easy enough.
Funny I was worried about the paint job we would get and mine seems to be okay so far.

add me to the list, just threw a check engine light comin home from work approx 1200 miles, the chevy app says "service emissions, I did not get the in truck message tho, unless I missed it. going to run my obd scan see what it says and call dealer. Also had a minor paint error at all top left of the rear cab looks like a paint chip or paint missed no big deal but makes me think if it was me or not cant see how it could have been
Keep us posted on the issue and I hope yours can get fixed as easy as mine. I ordered a Banks iDash so I can keep a better eye on things especially regen. I'll keep you posted.
 

· Registered
Joined
·
121 Posts
Discussion Starter · #20 ·
Rich, that is different than what my dealer said is my issue was (2nd DEF injector). Does the dealer have a quick fix for it? Hope we don't start having problems with the emission system as it changed for 2023 over the LM2 engines.
 
1 - 20 of 47 Posts
Top