Chevy Silverado and GMC Sierra Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First randomly of going in reverse. Truck will lock right up can go forward fine.if then reverse and lock up again no loud noises almost like it drops into park but if I give it Gas it will slam into reverse. Then recently I'll b driving and 4 ways will come on solid along with 4x4 light and abs and brake light will flash then all go away does it multiple times usually slow speed

Sent from my SAMSUNG-SM-G920A using Tapatalk
 

· Registered
Joined
·
135 Posts
I think the two are unrelated but I would like you to check a couple things. First thing is to check the transmission fluid. Sometimes if it low it will have a hard time shifting into gear. Get on a level surface and start the engine. Pull the dipstick for the transmission. It should say "Full Park" or "Full Neutral". If it says "Full Neutral" apply the E-Brake and put the transmission in neutral and check to see if it is full.
As for the lights coming on. Check to see if your wiper blades return to the correct position. There is a technical service bulletin that states that sometimes there is an issue with the harness or wiper motor that can cause those lights to come on. Part of the harness that I feel that they could have made better. If they do not return to the correct place I would recommend finding someone who is good with electrical and I will send you the TSB.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top