Chevy Silverado and GMC Sierra Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Well I'm using my iPhone and the app decided to close when I got done writing a damn near essay so this is going to be short. Bought the kit which includes the 25w ballast and the plug and play harness. Can't hook it up right at all. I ended up with an extra plug with two metal pieces on the end left over. Don't know what I'm doing. I hate electrical stuff. Any input on how to hook this up or pictures would be awesome. Here is a pic of what I have. I assume the tan plastic piece hooks up to the original wiring but who knows.
 

·
Registered
Joined
·
135 Posts
first of all if you live where there is salt cut off the two little metal ends, they will corrode and there is no way to tape them good enough, first hand experience, splice them directly to factory harness. I guess before you do that just plug them in first to see if set up works. They plug in where bulbs normally would. Then the other ends can only plug one way. You will have to find a spot to store ballast and capacitor.
 

·
Registered
Joined
·
135 Posts
if that doesn't make sense pm me
 

·
Registered
Joined
·
264 Posts
I'm interested in how this works out for you, it doesn't look like it's a true plug n play setup if you need to splice? Looking to get a set for my truck. Please keep us posted, and good luck!
 

·
Registered
Joined
·
135 Posts
i put hi/lows and fogs on mine, the fogs r as bright as lows, its like having two sets of lows on. The fogs are the easiest to install.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top