Chevy Silverado and GMC Sierra Forum banner
1 - 6 of 6 Posts

·
Registered
01 2500
Joined
·
4 Posts
Discussion Starter · #1 ·
01 6.0 140k miles
Cleaned the MAF sensor and throttle body aswell as the iacv.

(Not sure if this has anything to do with it) unplugged the MAF sensor while truck was running and it ran worse for a split second and then it idled like it always does. Plugged it back in and it ran the same way whether it was plugged in or not.

Truck idles around 500 RPM and intermittently shakes. Sometimes it is rougher than others and it catches itself. Never had stalled once on me nor does an engine light come on. Only does this while idling in and out of gear. Drives down the road perfect.
very few and far between I get a lean engine code. Stumped on what this could be. Maybe someone out there may have had a similar problem before I start dumping money on things I think it may be.

Any help is appreciated. Thanks I’m advance.
 

·
Registered
2004 Sierra 3500 6.0L, auto, extended cab, cab&chassis, upgraded to 4wd
Joined
·
1,511 Posts
check fuel pressure
make sure all the exhaust manifold bolts are present (and replace any broken off ones)
put a code reader on it and see if there are any codes (as there can be, even if the CEL is off)
 

·
Registered
01 2500
Joined
·
4 Posts
Discussion Starter · #3 ·
check fuel pressure
make sure all the exhaust manifold bolts are present (and replace any broken off ones)
put a code reader on it and see if there are any codes (as there can be, even if the CEL is off)
What should the 6.0 idle at when warmed up? I’m right around 500 on the dot. I feel the low idle could be some cause of this.
 

·
Registered
2004 Sierra 3500 6.0L, auto, extended cab, cab&chassis, upgraded to 4wd
Joined
·
1,511 Posts
Are you sure it's actual RPM is low, as the gauge can easily be off by 100+ rpm... I believe GM has it idle at right around 600 rpm (+-50) somewhere around there.
 

·
Registered
01 2500
Joined
·
4 Posts
Discussion Starter · #5 ·
On my scanner it’s reading roughly 500-575 up and down as it idles rough. Ignition timing is jumping between 15.2 and sometimes as high as 24.1 as it idles. No codes at all. Sometimes maybe once every 3k or so miles I get a p0171 code.
 
1 - 6 of 6 Posts
Top