Chevy Silverado and GMC Sierra Forum banner
1 - 4 of 4 Posts

· Registered
2010 L20 4800
Joined
·
157 Posts
Discussion Starter · #1 ·
Hi, my 2010 sierra, 4.8 (192000 km) by times feels like it's loosing spark for like a fraction of a second. Like goin in last gear (4l60e) at 40mph engine reving 1200 rpm: by times it feels like all sparks quit for 1/100th of a sec then back to normal. Sometimes its a bit worse(will do it more often in a day lets say) and other times its flawless. No codes. New plugs, wires seems ok, i use castrol edge 5w30, engine dont burn no oil..mmm clean k&n filter, run injector cleaner once in a while.

Oh and I forgot to mention, i replaced stock muffler with dual trush stainless steel muffler..I hear everything goin on into my engine! lol

Seriously i have my car mechanic course, and im pretty mechanically inclined but im beat with this.

Seems like a crank sensor loosing reference signal or loosing crank reading..but no codes.anybody similar problems?
 

· Registered
2010 L20 4800
Joined
·
157 Posts
Discussion Starter · #2 ·
Here is an update on this problem i had. After looking in 4 or 5 different auto parts shops and one gmc dealership for a crank sensor, nowhere to be found. I told my self...no codes, no crank sensors in stock (meaning they last for long time), its probably not the problem.

S
Knowing I have checked the coils and wires before by spraying water and dish soap right on top of them with eng. Running with no issues, I had ecm left or wiring or plugs. Had replace plugs about a month ago with cheap ac delco copper tip ones...ran good first but ignition had been goin worse and worse every day for the past 3 weeks or so. Took a chance and replaced them again with NGK'S TR5 platinums. That was the problem. Runs like a top since then. I had siee gapped them copper plugs also..not good. When oem calls for platinum plugs, put platinum on. Had irridiums on berore all that (ac delcos) were good for about 70000 km then tips start fallin off..I wasnt impressed with those either.
 

· Registered
2010 L20 4800
Joined
·
157 Posts
Discussion Starter · #4 ·
Thanks, yeah they do like oem spark plugs I agree. Those TR5's are the best I had on my 4.8 so far.Nice and smooth idle, good acceleration and doesnt skip a beat..got my oem muffler replaced by SS one, dual trush, dual outlets. I hear each cylinder firing.lol
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top