Chevy Silverado and GMC Sierra Forum banner
1 - 19 of 19 Posts

· Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hey everyone,

New to this forum as I recently purchased a 2011 Sierra 1500 crew cab. Everything was working fine until about a week ago. My wife had rolled down the passenger side window and it wouldnt go back up, I had to roll it up form the driver side window board. The rear passenger window does the same thing. I usually have to clicked the window button up a few times before it actually goes up.

Next up, the AUX port is loose and will cause the radio to go in and out, after some research I believe that is due to the port becoming unsoldered to the board and just needs to be resoldered.

All 3 of my brake lights have stopped working almost overnight. I am thinking it could be a short somewhere, maybe fuses, or a bad ground?

And lastly, the "Service Stabilitrak" and "Service Traction control" errors keep showing up. Some days it will come on in the morning, others the afternoon. But with all 4 of these issues going on at the same time, I am wondering if they are all related? Could it be related to one short, multiple shorts, multiple pieces going bad?

Does anyone have some ideas or guidance on where to start?

Thank you
 

· Registered
Joined
·
559 Posts
mrobb188 said:
....All 3 of my brake lights have stopped working almost overnight. I am thinking it could be a short somewhere, maybe fuses, or a bad ground?.....
If it was a short, the fuse would be blown. Have you checked the adjustment of the switch at the pedal that controls the brakes?
 

· Registered
Joined
·
2,249 Posts
Go to a local parts store and have them scan the codes for you. They do it for free (autozone) That would be a good starting point. Also start with the simplest electrical like the battery cable connections at both ends. These could all be related in some way but at this point who knows. If the windows work from the driver door it's a good indicator that the passenger side module is either bad or needs to be cleaned. The passenger side module also has something to do with other features in the truck but I don't know off hand what that is but it's totally unrelated to windows and door locks. Keep us posted and we will keep trying to help.
 

· Registered
Joined
·
3,323 Posts
The brake light switch is a pretty common failure on these trucks and will add to the stabilitrack and taillight issue. I would start by getting an AcDelco replacement for that. It usually happens more when the temperature drops, or at least it did for me. Dont bother with an aftermarket switch, they are garbage and you can get the part for about 10 bucks on ebay or amazon.

The window switches are cleanable. Just pull all the switches apart and clean the contacts with 2000 grit sandpaper and rubbing alcohol, you will see where the board has some corrosion spots. Put a little dielectric grease on the contacts before you put it back together and forget about it till your done with the truck.
 

· Registered
Joined
·
370 Posts
Did you buy this truck private-party or thru a dealership? Were you provided a carfax report? I've heard of flood cars coming with a lot of miscellaneous electrical issues.
 

· Registered
Joined
·
18 Posts
Discussion Starter · #9 ·
djlove said:
The brake light switch is a pretty common failure on these trucks and will add to the stabilitrack and taillight issue. I would start by getting an AcDelco replacement for that. It usually happens more when the temperature drops, or at least it did for me. Dont bother with an aftermarket switch, they are garbage and you can get the part for about 10 bucks on ebay or amazon.

The window switches are cleanable. Just pull all the switches apart and clean the contacts with 2000 grit sandpaper and rubbing alcohol, you will see where the board has some corrosion spots. Put a little dielectric grease on the contacts before you put it back together and forget about it till your done with the truck.
The temperature did just start to drop as of 2 days ago, and this started happening today. That very well may be the issue with that. I will have to try to clean the switches this weekend. The thing I am most concerned about right now are the taillights and stabilitrak, so hopefully the switches will fix all that.

Thank you for the input
 

· Registered
Joined
·
18 Posts
Discussion Starter · #11 ·
**Update**

Replaced the brake switch last night and reset all the codes. So far so good, brake lights are working and the ABS, traction control, and stabilitrak codes have not come back up (knock on wood :lol: )
 

· Registered
Joined
·
18 Posts
Discussion Starter · #15 ·
rbb010 said:
Hi, I have a similar problem. ABS and traction control lights on and DIC displaying service traction control, service Stabilitrak. How did you determine your problem was related to the brake switch? Thanks.
My truck was showing those errors for a few days and then the brake lights starting going out. When the brake pedal was pressed, all 3 brake lights would flash and then go off even though the pedal was still pushed. After some research, what a few guys said on here, and reading the codes, we guessed that the brake switch was the issue.

Honestly the part is about $15 and took less than 10 mins to install. It probably wouldn't be a bad idea to try it.
 

· Registered
Joined
·
18 Posts
Discussion Starter · #18 ·
djlove said:
The brake light switch does more than just turn the lights on so taking a 15 dollar stab at it is worth it vs 100 to get the codes read.
This is true considering replacing the switch also cleared up the ABS, service Stabilitrak, and service traction control errors.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top