Chevy Silverado and GMC Sierra Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I recently developed an issue with my truck. When I have my dual zone climate control on auto, I can hear a clicking or popping sound coming from what seems to be the front defroster. Its hard to really locate the sound. The sound will go away when I take it off auto and manually turn on the foot and window defrost heaters. I can only create the sound when going 45+ mph and when I move the heat around and up and down in my garage, I don't hear the sound or other issues with the climate control.

Any suggestions?

Thank you!!!
 

· Registered
2017 Silverado LTZ Z71
Joined
·
4,804 Posts
Disconnect the battery for about 30 sec and reconnect. Sometimes the auto climate system needs a reset.
 

· Registered
Joined
·
137 Posts
akarl2 said:
Hello, I recently developed an issue with my truck. When I have my dual zone climate control on auto, I can hear a clicking or popping sound coming from what seems to be the front defroster. Its hard to really locate the sound. The sound will go away when I take it off auto and manually turn on the foot and window defrost heaters. I can only create the sound when going 45+ mph and when I move the heat around and up and down in my garage, I don't hear the sound or other issues with the climate control.

Any suggestions?

Thank you!!!
i have the same noise on my 15 . ck'd. on line and it's another GM prob.and there was some videos on how to fix it on utube .if you have the plastic peace at the front window it is installed with clips about evey 8'' and they get loose and the wiring underneath will rattle also . the fix is to pull off both a+b pillars loose and the plastic peace will un clip then take strips of duct tape the size of the male clip and put the tape on them then replace the plastic strip .ck. for loose wiring while it is off . nothing like DUCT TAPING A NEW TRUCK ''''lol you would think GM would have alot of it ......
 

· Registered
2017 Silverado LTZ Z71
Joined
·
4,804 Posts
Completely different issue...
 

· Registered
Joined
·
509 Posts
You said it only happens after 45 mph + . Does it change when you change it to manual mode? Do you have a bug deflector on the front of your truck also? If so alot of times the bug deflector will cause the trim on the sides of your front window to rattle and it will sound like your dash is making the noise. There was also the problem with the trim rattling like said in the above post.
If your blend door motors are making the noise in the dash, I would shut all the power off to you climate control and then disconnect the battery and wait a few minutes and then reconnect the battery, start it and wait a few minutes to let them reset , then turn the climate control back on. There is a special way to reset them .. might want to double check that before doing it..
 

· Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
judsonlimited,1985,jmoore -

Yeah, when I change it to manual mode, the sounds goes away. I can actually turn the switch "auto" on and off and hear the noise turn on and off.

I do have a bug deflector. So it sounds like removing the deflector my be an issue. Even if its not the source of the noise in question, it may cut down on some highway noise.

I know there is an actuator near front defroster but I really don't want to replace that one if absolutely necessary. I've heard that one is hard to get to/replace. I'll reset the system first to see if that does anything.

lastcowboy-

I've actually already dissembled the dash as you've described :) Kind of sad this is a common issue. But that did not solve the issue.
 

· Registered
Joined
·
137 Posts
well i hope you find it.something i have noticed is if you are on auto and drop the temp. from hi heat to 82-86 the fan does blow alot harder and faster ...strange . but the bug d. could be a prob. and it made me think of the cowel by the front glass .had a 2500 and i traced it down to that and it would only do it at caetain speeds . on the 1500 you can push down on the clips on the dash and it stops thats what made me think thats what it was ......
best of luck. let us know .
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top