Chevy Silverado and GMC Sierra Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
170 Posts
Discussion Starter · #1 ·
My truck is a 2006 Chevy Silverado 1500 LT with 5.3 engine. When it idling it make a ticking noise. I already replaced both knock sensors because it was bad. After that it still making noises but not bad like it was before. I just don't know if it is from the motor, exhaust leak, or manifold here is a video that I took of the noise tonight.

 

· Registered
Joined
·
135 Posts
I have the exact some noise. Especially when the engine is cold. It is a typical thing on our vehicles unfortunately. Once it starts to get up in age it does it. It isn't really anything to worry about though. The best way to get rid of the noise is to have your timing chain replaced and heads cleaned up and checked for any wear. Most likely cause would be "valve slap". Just a valve that is a little worn but isn't causing any problems.
 

· Registered
Joined
·
170 Posts
Discussion Starter · #3 ·
ShaneB94 said:
I have the exact some noise. Especially when the engine is cold. It is a typical thing on our vehicles unfortunately. Once it starts to get up in age it does it. It isn't really anything to worry about though. The best way to get rid of the noise is to have your timing chain replaced and heads cleaned up and checked for any wear. Most likely cause would be "valve slap". Just a valve that is a little worn but isn't causing any problems.
Ok just want to make sure if it wasn't something that I have to be worry about. It have over 148,000 miles on it now and want to get dual exhaust done next summer on it and don't know if it will affect the noise when it tick like that.
 

· Registered
Joined
·
2,624 Posts
Yes, most of the group above assumed it was lifter tick which is common that is why they were asking for oil pressure. But you can also get a ticking noise with an exhaust leak. If you have some bolts that are busted or loose you'll get some ticking and loss of power as well as a change in fuel econ more than likely. Get that fixes and she should be back to normal sound.
 

· Registered
Joined
·
165 Posts
I agree with Mike, very common on nbs trucks. We have an 04 sierra with over 250k on the motor with a couple manifold bolts broken. Still runs like a champ.

Sent from my SAMSUNG-SM-N920A using Tapatalk
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top