Chevy Silverado and GMC Sierra Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
188 Posts
Discussion Starter · #1 ·
I have a dual double din in 08 silverado I'm installing with the PAC rp5 gm31 harness and cannot get the steering wheel controls programmed to the dual double din...any suggestions or has anybody else have this problem?
 

· Registered
Joined
·
188 Posts
Discussion Starter · #3 ·
Yeah it is "dual" brand I know cheap but it pretty nice actually and works good...and yes the dip switch fr the brand is labeled under "other" so I have it set to that

I used the remote wire and hooked to the remote blue turn on instead of the 3.5 mm jack for the steering control module off the PAC wich is ok...now the dual double din has 2 brown wires swc1 and swc2 off of stereo harness not hooked up because there are no brown coming from the PAC unit...now I'm thinking they need hooked up but to where?
 

· Registered
Joined
·
188 Posts
Discussion Starter · #6 ·
Yeah I was going to today but they are not open Sundays. Thanks though! Hope it works out I know it's a "dual" double din but I paid $125 for it and like it it does everything the expensive pioneers do and Bluetooth works amazing
 

· Registered
Joined
·
793 Posts
PAC's product reliability is pretty poor in my book. Back when I had a Pioneer HU in my truck I tried using the RP5 because it combined the steering wheel controls into a single unit as opposed to the PAC OS-4 which required a separate steering wheel interface. When I first connected it I tested all the functions and it worked great. However after I placed the HU and all the wiring back into the dash the steering wheel controls stopped working. Initially I thought maybe I had accidentally unplugged something or possibly pinched a wire. I pulled the HU back out and inspected all the connections and wires and everything checked out fine. A buddy of mine works at a car audio shop and he told me that they have had a lot of issues with PAC and no longer use any of their interfaces on their installs. So I put the OS-4 back in and soon after that I purchased the Advent OGM-1 to replace the Pioneer HU. I haven't used it myself but I've heard that the iDataLink Maestro interface, though a bit on the pricey side, works very well.
 

· Registered
Joined
·
188 Posts
Discussion Starter · #10 ·
B Cubed said:
PAC's product reliability is pretty poor in my book. Back when I had a Pioneer HU in my truck I tried using the RP5 because it combined the steering wheel controls into a single unit as opposed to the PAC OS-4 which required a separate steering wheel interface. When I first connected it I tested all the functions and it worked great. However after I placed the HU and all the wiring back into the dash the steering wheel controls stopped working. Initially I thought maybe I had accidentally unplugged something or possibly pinched a wire. I pulled the HU back out and inspected all the connections and wires and everything checked out fine. A buddy of mine works at a car audio shop and he told me that they have had a lot of issues with PAC and no longer use any of their interfaces on their installs. So I put the OS-4 back in and soon after that I purchased the Advent OGM-1 to replace the Pioneer HU. I haven't used it myself but I've heard that the iDataLink Maestro interface, though a bit on the pricey side, works very well.
How did you hook the swc controls up to the OGM-1 since that unit doesn't have the 3.5 mm jack either?......and yeah I may look into the idatalink maestro if I can't figure out this pac unit
 

· Registered
Joined
·
793 Posts
nicks93hotrod said:
How did you hook the swc controls up to the OGM-1 since that unit doesn't have the 3.5 mm jack either?......and yeah I may look into the idatalink maestro if I can't figure out this pac unit
The OGM-1 doesn't require any interface adapters.
 

· Registered
Joined
·
188 Posts
Discussion Starter · #13 ·
I still can't figure this out...instead of having the phone jack in the back of my radio for steering wheel controls I have a sw1 and sw2 and swg ground and I have to connect the blue wire with yellow stripe from PAC unit but not sure where it goes I have installed alot of radios but can't figure this one out...anybody know an installer on this forum or have had the same problem ?
 

· Registered
Joined
·
793 Posts
I'd either return the Dual deck for a refund or sell it and buy a brand that is known to work with the RP5
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top