Chevy Silverado and GMC Sierra Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
656 Posts
Discussion Starter · #1 ·
Okay, so I had my mirror replaced 11 months ago due to failure of the temp and compass. So last week, went to college it worked fine. Got out of college and mirror said OC. So I've done research, said replace the sensor. I've tried 2 different sensors, no luck. i saw on here to test the ohms, i get a brief reading of any where between 500 and 1300 ohms. I've traced wiring everything seems intact. Could it really be the mirror again? It's not even a year old yet....
 

·
Registered
Joined
·
656 Posts
Discussion Starter · #3 ·
i wouldn't think so. i havent been in any accidents and i live in colorado. it's bone dry here so i doubt its corrosion. but i guess i could cut things open and see.
 

·
Registered
Joined
·
3,346 Posts
difference in location changes how you think. Im in buffalo so first thing i look for is corrosion. Your truck will never rot in Colorado.

Those motherboards do go bad its really bad luck if you get two in a row though.
 

·
Registered
Joined
·
656 Posts
Discussion Starter · #6 ·
I did check the ohms....: "i saw on here to test the ohms, i get a brief reading of any where between 500 and 1300 ohms." and i know on the first mirror it was something in the mirror.
 

·
Registered
Joined
·
1,751 Posts
I read where you said that, but you didn't say if you checked it at the mirror connector or the sensor behind the grille. So I wanted to throw that out there.

Is it the style that shows temp and compass at the same time or do you have to push the button and toggle between the two?
 

·
Registered
Joined
·
1,829 Posts
Sensors can be crap when they are brand new. Maybe replace it again?
 

·
Registered
Joined
·
656 Posts
Discussion Starter · #9 ·
checked at the mirror. and it shows both at the same time. I've tried 2 different sensors for the truck. no luck.
 

·
Registered
Joined
·
1,751 Posts
Too bad, if it was the other style, I have a few spares in my garage. But the newer style like you have are harder to find. It's what I installed in my S10 and my Silverado though and I love them. If you know anyone local with the same mirror, you could plug it in and see if it works correctly or not. But it's starting to sound like something is bad in the mirror.
 

·
Registered
Joined
·
656 Posts
Discussion Starter · #11 ·
So update, haven't done anymore testing but while out getting lunch today the mirror finally showed a temp of -38 degrees the -40 degrees then back to OC so I think it's a computer issue....?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top