Chevy Silverado and GMC Sierra Forum banner
1 - 20 of 20 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 2021 Sierra 1500 X31 5.3 ecotech with 4200 miles on it. Today, when sitting at a light the whole truck vibrated like it was going to stall. The light turned green and when I accelerated there is a popping sound from the engine constantly while driving. At first I thought my truck backfired while accelerating. popping noise in engine, rough vibration on idle Has anyone else experienced this?
I made a appointment with GMC Dealer in 2 weeks
 

· Registered
2003 Silverado 1500 LS
Joined
·
1,760 Posts
I seriously doubt anyone here has experienced that exact issue. However, my suggestion would be to open hood and look very carefully at all wiring connectors and vacuum hoses. Maybe something just fell off.

Please post solution, when found. Good luck.
 

· Registered
2021 Trail Boss LT L84 10L90
Joined
·
334 Posts
Dropped a lifter, with the popping noise I will venture a guess that it was an exhaust lifter.

Don't drive it till you get it to the dealer. It is under warranty, and a new bulletin states to replace them all on BOTH sides. Make sure your dealer is aware of that.
 

· Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I have always learned to ask questions to any problem, to gather as much knowledge as I can to protect myself plus to and have a greater understanding to problem.
Knowledge is power.
Yes it's under warranty.
Yes it's at the dealership as of today.
No the truck hasn't even had it's first service.
I thank all those that have responded with positive feedback it was a great help while talking with the GMC personnel.
I will keep you all posted on the diagnostics as we move forward.
 

· Registered
Joined
·
16 Posts
Did you get it figured out? What did the dealer say?

I am currently experiencing the exact same issue on my 2021 GMC AT4. Took it in. They said it was a "bent lifter." I just posted to the forum about it, however it has yet to be approved.
 

· Registered
2003 Silverado 1500 LS
Joined
·
1,760 Posts
Jefvm said:
Just by chance a guy I work with had the same problem 3 times during the 4 months he's owned it.
I dropped my truck off Thursday and he picked his truck up Friday.
Thanks for posting the diagnosis and 'fix'.

Although, based on your comment quoted above about that guy having his 'fixed' 3 times in 4 months, I mean, that's just crazy. Has the dealer replaced all the lifters on that truck 3 times?????? :eek:
 

· Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
GMC just put out bulletin stating if the P0300 code appears they are required to replace them all as they did with mine.
His truck they piecemealed starting with the 1 cylinder, next they did the one side, then they had the bulletin come out and they did both sides as the did all future trucks as mine.
Unfortunately he had to go through the process.
Knock on wood I have no future problems.
Good luck.
 
1 - 20 of 20 Posts
Top