Chevy Silverado and GMC Sierra Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Today I swapped out my factory radio for a Pioneer AVH-X2800BS using a pac RP5-GM31. I got it all installed and can not get my steering wheel controls to work. I read the instructions and can not seem to get them working at all. Anyone who has installed the RP5-GM31 have any tricks or ways to get the controls to work.
 

·
Registered
Joined
·
110 Posts
Did you check all of your connections? Made sure everything was seated properly?
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Yes I have. It should just be plug in play once all the connections are correct?
 

·
Registered
Joined
·
110 Posts
As far as i know it should be..... if it was me... when in doubt, meter out
 

·
Registered
Joined
·
25 Posts
I had some trouble figuring out how to program my pac steering wheel adapter when i just installed my pioneer 2700. I youtubed it and made a lot more sense
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
I'll tackle it tomorrow. I'll triple check my connections and make sure all the settings are set up correctly. I don't know if there is anything I have to do to the head unit since it is plugged in through the AUX port on the back? Didn't see anything about that.
 

·
Registered
Joined
·
25 Posts
Out of curiosity i did some research. Yours is the all in one where as mine has a seperate module for the steering wheel controls. I skimmed through your instructions and it says it is preprogrammed but the selecter switch has to be on 7 (which i assume you have done that). The other thing is mine had 3 aux inputs. I believe i had to use the top right when looking at the back of the unit. Your installation appears to be much simplar then mine was!
 

Attachments

·
Registered
Joined
·
47 Posts
Discussion Starter · #8 ·
Yes it is on 7. I'll check the rest tomorrow. Love the head unit though. So many options and got it for $213 on Amazon.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #9 ·
Well it was something simple. I put the cable from the RP5 into the aux port and it needed to be in the W/R port. Which I assume is wired remote.
 

·
Registered
Joined
·
25 Posts
Good deal man, i figured it had to be something simple
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top