Chevy Silverado and GMC Sierra Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
149 Posts
Discussion Starter · #1 ·
Hey all,
Took my (fairly new to me) 2000 Sierra to work the last couple days and seems like I need to have the throttle down further than what it should be to keep at 65-70. My RPM is 1900-2000 steady once I'm up to speed. Truck's got the 4.8 - 4L60e and 4wd, I believe the ratio is 3.73, tires are 265-75r16. Engine runs really well which is why I'm thinking it's something in the trans and hoping it just needs a fluid/filter service. It doesn't seem to be slipping. Getting on the highway it downshifts, then as I'm coming off the throttle is sometimes downshifts again. Any ideas? (no TPS codes or any codes come up)
 

· Registered
Joined
·
149 Posts
Discussion Starter · #3 ·
170k. I know the tips and tricks for the flush/filter on the 4L60e like the back of my hand. Nice thing about having a WT is I can move the transfer case shifter to get to the linkage torx bolts on top.. I know the larger than stock tire affects it, but didn't think it should affect it too much since it's got the 3.73gears, unless the tire shop didn't inflate them right. They're KO2 and I read those like to be higher in PSI than the stock 32PSI.. Doesn't feel/sound like my brakes are dragging either
 

· Registered
Joined
·
149 Posts
Discussion Starter · #4 ·
Well definitely looking at TPS now. Left work, truck didn't want to accelerate from a stop..had rpm, not the speed. More like it started in third or 4th not so much a slip. then once I let off the throttle and back on it was fine. Got home, checked fluid, had great color didn't smell burnt, read a little high cause the truck wasnt completely level...
 

· Registered
Joined
·
149 Posts
Discussion Starter · #7 ·
Just got into the house. Did a voltage check on the TPS .6v at no throttle 4.5-4.6v at full throttle. No dead spots. Guess I'll do a flush and filter this weekend to start with.. Maybe just a flush before I mess with pulling the pan off. Could there being too much fluid cause it? It seemed like it read too high even on the small incline I was on.
 

· Registered
Joined
·
149 Posts
Discussion Starter · #8 ·
I think my MAF was giving a false reading. Last week I did an oil change and found out the truck had a KN air filter. I had a feeling it was over oiled, and there was a small puddle of KN oil in the bottom of the air box. Cleaned that up at the time. Checked last night there was another puddle just after a week. Put in the paper filter I had on the shelf. Drive it this morning it felt A LOT better. Got up to speed better on the on ramp too. Not saying the filter was to blame, whoever oiled it was to blame.
 

· Registered
Joined
·
149 Posts
Discussion Starter · #10 ·
Yup. I've had KN on most of my vehicles, never an issue. Doesn't need a generous coat of oil. I didn't clean the MAF last night and it just ran better. It was late and I was tired. In fact so tired I forgot to lock the dipstick for the trans. Thankfully my drive to work is only 8 miles and I didn't lose too much fluid. Noticed when I turned the defrost on all I smelled was trans fluid and i knew right away.. ooops :lol:
 

· Registered
Joined
·
149 Posts
Discussion Starter · #13 ·
Well good news and bad.. the motor is fine. Pulled real good. That's the good news no issues with the engine.. the bad is a 3rd great slip. Got a chance to shift manually at heavy throttle on the way to pick up dinner.. 1-2 was great. 2-3? Not so much. Slipped bad and engine hit 5k rpm then shifted. Kind of bummed, but for what I paid, I still made out OK compared to what the truck was worth..
 

· Registered
Joined
·
149 Posts
Discussion Starter · #14 ·
Have to pull the pan off. I'm suspecting that the filter came out of the pickup. I've seen that happen before. I took out the extra fluid. Almost a gallons worth then had no gears at all. No fwd, or reverse. I'm thinking they filled up so much extra to 'bypass' the filter... Idiots
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top