Chevy Silverado and GMC Sierra Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My Transmission is not shifting into gear????. My tranny has never slipped and the other day I pulled it into the back of my shop and unloaded some stuff and about 20 min. later I started it up and it wouldn't shift into reverse so I tried to shift into drive and it did nothing it revs up and runs fine. But when I shifted back to Park I heard a bit if a grinding noise( maybe the flywheel?) It won't even shift into park it stays in Nuetral no matter what gear I am in. I had my daughter shift the gears for me as I was under the truck and the cable appeared to still be working shifting back and forth. Is there an electronic component that may have gone out. Also I checked my tranny fluid and it was full and the correct color? Any suggestions
 

·
Premium Member
Joined
·
13,346 Posts
Are you sure the transfer case is not in neutral? If not, then I'd suspect the link from the shift lever (inside the transmission) may have come loose and it is not moving. If that is the case, you will probably be able to fix it by removing the transmission pan and not having to remove the transmission. I'm leaning towards the transfer case being in neutral because of the grinding you are hearing when you try to put it in park. It sounds like the transmission is working fine, but there is no powere coming out of the transfer case. The grinding is probably the parking pawl engaging while the shaft is turning in the transmission.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I have talk to a few people and have not heard that possibility yet. A linkage in the case sounds like that could be it since the linkage on the outside seems to be working fine, I'll take a look and let you know. Thanks
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top