Chevy Silverado and GMC Sierra Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My 2015 2500hd 6.0 gas is throwing u0140, u0101 and a u0102 codes now I disconnect the battery it turns of for about 30 miles then comes back not sure if it has something to do with the power chip that I recently removed from the truck or if it is something else any help would be appreciated thanks
 

·
Super Moderator
2015 High Country Duramax
Joined
·
18,568 Posts
Those are all communication codes. Meaning that the controllers, which in this case is the BCM, TCM, and TCCM, aren't communicating on the data network.

What kind of "chip" was it, and how/where was it installed? And did it start as soon as you removed it? Any other work done to the truck lately?
 

·
Registered
2012 Silverado 2500HD 4x4
Joined
·
1,948 Posts
Google the codes,, I do not have my scanner book with codes now but I know you can fund them online!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Those are all communication codes. Meaning that the controllers, which in this case is the BCM, TCM, and TCCM, aren't communicating on the data network.

What kind of "chip" was it, and how/where was it installed? And did it start as soon as you removed it? Any other work done to the truck lately?
It was a bully dog tuner you plug in the obd2 and I went to advanced to get a battery and he just unplugged it to put his charger on and when I went to reinstall the tune it froze up so thinking something is screwed up with the computer maybe?
 

·
Registered
Joined
·
3,442 Posts
It was a bully dog tuner you plug in the obd2 and I went to advanced to get a battery and he just unplugged it to put his charger on and when I went to reinstall the tune it froze up so thinking something is screwed up with the computer maybe?
Maybe next time start with that! You are going to have to reinstall your tune or the factory tune. Either way it sounds like you need to get ahold of Bully Dog.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Those are all communication codes. Meaning that the controllers, which in this case is the BCM, TCM, and TCCM, aren't communicating on the data network.

What kind of "chip" was it, and how/where was it installed? And did it start as soon as you removed it? Any other work done to the truck lately?
Started to reinstall the bully dog and it said restore to factor then reinstall so I did that and then reinstalled it and so far so good after 100 miles.
 
1 - 8 of 8 Posts
Top