jQuery not supported.



1990 1500 - multiple electrical issues with lights

Forum rules
This is NOT the place to post topics that could be better classified in another category. Please make every attempt to post in an appropriate category before posting here.

1990 1500 - multiple electrical issues with lights

Postby sirmacbain [OP] » Jan 13 2021, 8:09pm

With headlights off:
Front running lights work.
Turn signals work (front and rear)
Brake lights don't work when brake is depressed.
Rear running lights don't work.
Intermittent/inconsistent rear backup lights.
Depressing hazard light switch causes the rear brake/running lights to stay on.

With headlights on:
Same as above BUT turn signals don't work!

- headlights and hi beams work fine
- I've replaced the brake switch (on the brake lever).
- I've put in new bulbs, and new light fixtures (all external lights).
- I've put in a new hazard switch.

None of this has changed the behavior at all.

The electrical is fine for the radio, dash, interior lights, heat/ac, and engine/computer.

Any pointers on how to figure out these issues? Are they a single cause like a bad electrical ground? Or, are there several issues with the electrical system? And, how could something like turning on the headlights make the turn signals stop working (if it was just a ground)?
Original Poster
sirmacbain
Newbie
Newbie
Posts: 1
Topics: 1
Joined: Jan 13 2021, 7:01pm
Location: St Paul
Year: 1990
Make/Model: Chevrolet Silverado
Extra Info: Scottsdale 5.0L 4x4M
Group Membership:
Registered users

Re: 1990 1500 - multiple electrical issues with lights

Postby Larry-Cleveland » Jan 13 2021, 10:00pm

In an older truck like this, you do not have to worry about electronics. It is most certainly a ground problem. Clean all the grounds you can find. I would also make up some wires with clips on them to put on some temporary grounds from the battery (-) to the different body parts to see if that helps.
User avatar
Larry-Cleveland
Combustion on 1 piston [L2]
Combustion on 1 piston [L2]
Posts: 178
Topics: 13
Images: 12
Joined: Dec 18 2019, 9:09pm
Years of membership: 1 year of membership
Location: Ohio
Year: 2009
Make/Model: Chevrolet Silverado
Extra Info: 2500 60L 4X4 Flatbed
Group Membership:
Registered users

Re: 1990 1500 - multiple electrical issues with lights

Postby Chevy-SS » Jan 14 2021, 12:49am

Yep, yep ^^^^^^^^^ almost 100% certainty it's bad ground(s). Start cleaning and sanding and buying new straps.
User avatar
Chevy-SS
Combustion on 2 pistons [L2]
Combustion on 2 pistons [L2]
Posts: 242
Topics: 5
Joined: Dec 16 2019, 7:17pm
Years of membership: 1 year of membership
Location: Rhode Island
Year: 2003
Make/Model: Chevrolet Silverado
Extra Info: LS 4.8L
Group Membership:
Registered users

Return to Uncategorized Truck Topics

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

issues lights electrical multiple make start running parts body problem system different rear truck work front engine same light

It is currently Jan 18 2021, 8:17pm

  • Sponsor
Login  •  Register
Uncategorized Truck Topics Forum
Uncategorized Truck TopicsThis is an all-purpose area for Silverado/Sierra truck related discussion. These forums typically contain truck related but ill-assorted topics unfit for any other category.
To create a new topic in Uncategorized Truck Topics, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: BowTieZ71BowTieZ71 is online!, shakenfakeshakenfake is online! and 28 guests