jQuery not supported.



Slow throttle response/Low power

Slow throttle response/Low power

Postby RV1966 [OP] » Aug 27 2013, 2:37am

When I put my 2002 silverado 1500 4.3l automatic in gear and step on the gas pedal it is very slow to take off. Once up to speed say 45-50 i have throtle response. it just happens when first starting out. Any ideas? I have changed out the inline fuel filter and the in tank fuel pump has been replaced. All input is appreciated.
Original Poster
RV1966
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Aug 27 2013, 2:21am
Years of membership: 7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership
Location: United States
Year: 2002
Make/Model: Chevrolet Silverado
Extra Info: 4.3L 1500 Plain Jane
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby xMOWERYx » Aug 27 2013, 4:41am

Sounds like it's not getting enough fuel or air. Do you have a CAI?
Image
xMOWERYx
2009 GMC Sierra Ext. Cab SLE Z71
5.3L With HP Custom Tune
Flowmaster Dual Exhaust
K&N CAI
Rough Country Leveling Kit
Westin Brush Guard
User avatar
xMOWERYx
Combustion on 7 pistons [L2]
Combustion on 7 pistons [L2]
Posts: 767
Topics: 18
Images: 10
Joined: Jun 09 2012, 6:26pm
Years of membership: 8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
Location: Missouri
Year: 2009
Make/Model: GMC Sierra
Extra Info: 5.3 Z71 Ext. Cab
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby RV1966 [OP] » Aug 27 2013, 3:41pm

Just what is stock, no aftermarket CAI.
Original Poster
RV1966
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Aug 27 2013, 2:21am
Years of membership: 7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership
Location: United States
Year: 2002
Make/Model: Chevrolet Silverado
Extra Info: 4.3L 1500 Plain Jane
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby xMOWERYx » Aug 27 2013, 4:47pm

Your timing chain might have something to do with it. Could be stretched out. There are a ton of little sensors you can look up for it and just stat going from there.
Image
xMOWERYx
2009 GMC Sierra Ext. Cab SLE Z71
5.3L With HP Custom Tune
Flowmaster Dual Exhaust
K&N CAI
Rough Country Leveling Kit
Westin Brush Guard
User avatar
xMOWERYx
Combustion on 7 pistons [L2]
Combustion on 7 pistons [L2]
Posts: 767
Topics: 18
Images: 10
Joined: Jun 09 2012, 6:26pm
Years of membership: 8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
Location: Missouri
Year: 2009
Make/Model: GMC Sierra
Extra Info: 5.3 Z71 Ext. Cab
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby xMOWERYx » Aug 27 2013, 4:48pm

Someone might be able to narrow it down with a scanner that will read your fuel spikes while driving. That way you know if you're running lean or not.
Image
xMOWERYx
2009 GMC Sierra Ext. Cab SLE Z71
5.3L With HP Custom Tune
Flowmaster Dual Exhaust
K&N CAI
Rough Country Leveling Kit
Westin Brush Guard
User avatar
xMOWERYx
Combustion on 7 pistons [L2]
Combustion on 7 pistons [L2]
Posts: 767
Topics: 18
Images: 10
Joined: Jun 09 2012, 6:26pm
Years of membership: 8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
Location: Missouri
Year: 2009
Make/Model: GMC Sierra
Extra Info: 5.3 Z71 Ext. Cab
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby RV1966 [OP] » Aug 28 2013, 3:45am

Thanks for the input.
Original Poster
RV1966
Newbie
Newbie
Posts: 3
Topics: 1
Joined: Aug 27 2013, 2:21am
Years of membership: 7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership
Location: United States
Year: 2002
Make/Model: Chevrolet Silverado
Extra Info: 4.3L 1500 Plain Jane
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby Sgoody43 » Aug 28 2013, 4:03am

I had a 99 Silverado 4.3 and I had this same issue. No power until I was already driving. It never felt as bad because the issue started off slow and got worse. It eventually started to stall. I had to have it smog and didn't pass because it had a mis. My mechanic later discovered the timing chain stretched out and was out of timing. Put in time and truck felt like new again. Just my experience
Sgoody43
Firing on 1 cylinder [L1]
Firing on 1 cylinder [L1]
Posts: 19
Topics: 4
Images: 8
Joined: Jun 05 2013, 6:05pm
Years of membership: 7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership7 years of membership
Location: CA
Year: 2008
Make/Model: Chevrolet Silverado
Extra Info: Crew Cab 5.3
Group Membership:
Registered users

Re: Slow throttle response/Low power

Postby Wacker » Aug 28 2013, 4:12am

I seafoamed my engine and my trottle response did increase plus with the age of your truck it would be good to give her a cleaning anyways. I used the method talked about in this thread.

Seafoam smoke show
Image

Sauerado: No no no. If I was going to go gay I could land a way hotter guy than him.
User avatar
Wacker
Armed Forces
Armed Forces
Shifting into Second Gear [L3]
Shifting into Second Gear [L3]
Posts: 1230
Topics: 39
Images: 93
Joined: Jan 27 2013, 5:50am
Years of membership: 8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership8 years of membership
Location: Norfolk,VA
Year: 2000
Make/Model: Chevrolet Silverado
Extra Info: 5.3 Z71
Group Membership:
Servicemen
Registered users

Return to Vortec 4300 4.3L V6

 

  • Similar topics
    Replies
    Views
    Last post

Common search terms

power fuel slow throttle response while didn might issue again running first same thanks engine stock getting used

It is currently Mar 03 2021, 6:43pm

  • Sponsor
Login  •  Register
Vortec 4300 4.3L V6 Forum
Vortec 4300 4.3L V6 specific.
To create a new topic in Vortec 4300 4.3L V6, click this button:
Previous topic Next topic
Sitewide News Sitemaps & Feeds

Who is online

Users browsing this forum: No registered users and 5 guests